OCS Download

Do you want to install Open Conference Systems on your server? Installing this program will allow you to host conference web sites for you and your colleagues.

System Requirements

You will need, installed on your Web server:

  • PHP: >= 4.2.x (including PHP 5.x); Microsoft IIS requires PHP 5.x
  • MySQL: >= 3.23.23 (including MySQL 4.x) or PostgreSQL 7.1 (including PostgreSQL 8.x)
  • Apache: >= 1.3.2x or >= 2.0.4x or Microsoft IIS 6
  • Operating system: Any OS that supports the above software, including Linux, BSD, Solaris, Mac OS X, Windows.

As PKP does not have the resources to test every possible combination of software versions and platforms, no guarantee of correct operation or support is implied. We welcome feedback from users who have deployed OCS on systems other than those listed above.

If you do not understand these system requirements, consult your department’s technical administrator. If you are looking for OCS hosting support, PKP Publishing Services offers a full range of hosting and consultation services.

Legal Information
This program is free software; you can redistribute it and/or modify it under the terms of the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details.

You should have received a copy of the GNU General Public License along with this program; if not, write to the Free SoftwareFoundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA

Please read the software license for a summary of its terms and conditions. Please note that by installing and/or modifying this program, you are agreeing to the terms and conditions listed in the software license.

Contacting Us

Download Instructions 

Current Stable Release (March 16, 2012)

Previous Releases

Note: PKP has discovered a security flaw affecting OCS 2.3.0 to 2.3.4 (inclusive). It is strongly suggested that users upgrade their installations to the most recent release of OCS, or follow the instructions at this Bugzilla entry to correct the problem.

Note: PKP has discovered a security flaw affecting OCS 2.3.0.x, 2.3.1.x, and 2.3.2.x. It is strongly suggested that users upgrade their installations to the most recent release of OCS, or apply the patches linked from this Bugzilla entry to correct the problem.

WARNING: A remote file inclusion bug exists in all releases of OCS prior to OCS 1.1.7. Please apply the patch at http://pkp.sfu.ca/support/forum/viewtopic.php?p=4057 as soon as possible.

For installation instructions, decompress the downloaded file and consult the README document. If you continue to have difficulty installing OCS, consult your technical administrator. The Public Knowledge Project may be able to provide further advice as required and, if circumstances require it, may be able to, at least initially, host a conference’s version of OCS.