Installation Problem

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
The Public Knowledge Project Support Forum is moving to

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.
Posts: 4
Joined: Fri Jun 01, 2007 4:02 am
Location: Norwich, UK

Installation Problem

Postby ariadatexts » Fri Jun 01, 2007 4:19 am

Hi there,

I'm interested in migrating an online journal at my university to OJS but am having problems trying to install it.

My set up: Debian GNU/Linux; PHP 5.2.2; MySQL 5.0.41; Apache 2.2.3.

So I extracted the PHP into a directory, changed the owner of and cache/ to ariada:www-data and changed the permissions to 664 and 775 respectively.

I then tried pointing my browser (Konqueror) to the index.php page. It said that it didn't recognise the MIME type of the response. So I tried with Firefox which gave the same result. (Unfortunately I can't remember [or reproduce] what it said the MIME type was; though it may have been something like PHTML?)

So I tried running $ php tools/install.php instead. It complained about exceeding its memory allowance.

So I opened up in my text editor and started filling it in. During this step I also created a MySQL database (but with no tables).

Now when I run # php tools/install.php (as root) I don't get the memory error, but I get this error:

<h1>DB Error: Table 'ariadaojs.plugin_settings' doesn't exist</h1>OJS: DB Error: Table 'ariadaojs.plugin_settings' doesn't exist

(I also now get this error if I open the index.php page in my browser.)

So I tried looking in the source code for the required database schema (hoping to be able to create the database manually) but it doesn't seem to be obvious what tables/fields are required ($ grep -Rn "CREATE" ojs/* returns quite a few things; and I found a function called getSQL() but it seems to make quite a few nested calls and its really very difficult trying to follow the flow of execution in a language I haven't used for ages!)

Can anyone suggest how I may be able to install OJS?


Posts: 4
Joined: Fri Jun 01, 2007 4:02 am
Location: Norwich, UK

More Problems

Postby ariadatexts » Fri Jun 01, 2007 5:18 am

OK, I've been fiddling around with this and it seems that the hack which finally made it work was altering the php.ini file and increasing the memory_limit option to "12M" (from "8M"). This made it possible to install with the Web front-end, I guess because the PHP memory error was making it return a half-baked page.

Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm

Postby asmecher » Fri Jun 01, 2007 1:50 pm

Hi ariadatexts,

Unfortunately, PHP has been known to behave somewhat unpredictably when the memory limit is exceeded -- particularly with Apache 2.x. However, as long as you're running with a memory_limit of 12M or 16M, OJS should work fine.

Alec Smecher
Public Knowledge Project Team
Don't miss the First International PKP Scholarly Publishing Conference
July 11 - 13, 2007, Vancouver, BC, Canada

Return to “OJS Technical Support”

Who is online

Users browsing this forum: No registered users and 2 guests