links in Announcements?

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.
arachne
Posts: 52
Joined: Sun Feb 11, 2007 3:46 pm
Location: Vancouver
Contact:

links in Announcements?

Postby arachne » Fri Mar 30, 2007 5:54 pm

Hiya - how can I put live links into Announcements? I tried a simple HTML link but it created a weird hybrid that sent me back to the homepage.

cheers,
jenea

arachne
Posts: 52
Joined: Sun Feb 11, 2007 3:46 pm
Location: Vancouver
Contact:

Postby arachne » Fri Mar 30, 2007 6:05 pm

on a related note, I would really like to make the links live in my temporary message I've posted on the 'Current' & 'Archive' pages so that people can find the issues on our old site easier while we get our old issues loaded up on the new site.

See here what I mean:
http://www.thirdspace.ca/journal/issue/current

sorry for the non-PHP-coder Qs!

cheers,
j.

asmecher
Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm
Contact:

Postby asmecher » Mon Apr 02, 2007 9:48 am

Hi Arachne,

To make a link active in the temporary message, simply use HTML tags in the template, e.g.:

Code: Select all

<a href="http://some-link-URL-here">Link label goes here</a>
Likewise, you should be able to put links into announcement bodies. (The announcement titles do not support HTML tags, however.) If you can describe what's happening in more detail, I might be able to suggest a fix.

Regards,
Alec Smecher
Open Journal Systems Team
---
Don't miss the First International PKP Scholarly Publishing Conference
July 11 - 13, 2007, Vancouver, BC, Canada
http://ocs.sfu.ca/pkp2007/

arachne
Posts: 52
Joined: Sun Feb 11, 2007 3:46 pm
Location: Vancouver
Contact:

Postby arachne » Mon Apr 02, 2007 9:01 pm

Ok - now everything worked fine on the announcements, I must have done something wrong with the HTML.

The lesson here - don't leave out the last quote on your hrefs! :oops:

Thanks for the tip re the template - I was trying to put the href in the locale.xml key rather than the template itself.

cheers,
j.


Return to “OJS Technical Support”

Who is online

Users browsing this forum: No registered users and 1 guest