Register page ERRORS

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.
DavidRad
Posts: 47
Joined: Sun Mar 25, 2007 4:49 pm
Location: Saugerties, NY
Contact:

Register page ERRORS

Postby DavidRad » Sun Mar 25, 2007 4:57 pm

I'm using 2.2.0.0 via CVS,

OS platform FreeBSD
PHP version 4.4.6
Apache version Apache/1.3.37 (Unix) PHP/4.4.6 with Suhosin-Patch
Database driver mysql
Database server version 3.23.59-nightly-20050301

When trying to register with a journal I recieve this error:

Page with error: http://24.161.80.157/mhr/ojs2/index.php ... r/register

####################
Notice: Array to string conversion in /usr/home/mhr/www/ojs2/classes/core/Transcoder.inc.php on line 32

Warning: Cannot modify header information - headers already sent by (output started at /usr/home/mhr/www/ojs2/classes/core/Transcoder.inc.php:32) in /usr/home/mhr/www/ojs2/classes/template/TemplateManager.inc.php on line 194
####################

Thanks for any direction! Great app! I hope to be able to use its powerful functions.

Thanks again.

DavidRad
Posts: 47
Joined: Sun Mar 25, 2007 4:49 pm
Location: Saugerties, NY
Contact:

Tried disabling plugins

Postby DavidRad » Mon Mar 26, 2007 4:28 am

I disabled System Plugins: Layout and Translator since both seemed invloved. Then I cleared cache and still the errors persist. Any help would be appreciated. Thanks.

DavidRad
Posts: 47
Joined: Sun Mar 25, 2007 4:49 pm
Location: Saugerties, NY
Contact:

Tried to delete blank spaces...

Postby DavidRad » Mon Mar 26, 2007 8:05 am

Apparently similiar errors occur when blank spaces are left in front or after the <?php ... ?> though that was not it either. Any direction folks? Thanks.

mj
Site Admin
Posts: 304
Joined: Fri Mar 26, 2004 9:32 am
Location: Toronto, Canada
Contact:

re: Register page ERRORS

Postby mj » Mon Mar 26, 2007 9:42 am

Hi Dave,

This error (technically, a warning) came from a bug that the registration page was sending an empty array into the transcoder (to be normalized to UTF-8) before being filled out. Thanks very much for catching it, I have fixed it in CVS and you should be able to get the corrected file (either by a CVS update or just pulling down the new classes/form/Form.inc.php).

Regards,
MJ Suhonos
OJS Development Team

asmecher
Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm
Contact:

Postby asmecher » Mon Mar 26, 2007 10:08 am

Hi Dave,

FYI, just in case you're not aware -- you're using pre-release code, so you're likely to run into the odd bug. Please let us know as you come across them; we appreciate the extra set of eyes. Be warned, though -- if you're loading data into a pre-release OJS installation, you may have trouble when it comes time to upgrade. We script upgrades as part of the release process, so if you're using code between releases, upgrades will be complicated.

Regards,
Alec Smecher
Open Journal Systems Team
---
Don't miss the First International PKP Scholarly Publishing Conference
July 11 - 13, 2007, Vancouver, BC, Canada
http://ocs.sfu.ca/pkp2007/

DavidRad
Posts: 47
Joined: Sun Mar 25, 2007 4:49 pm
Location: Saugerties, NY
Contact:

Thanks!

Postby DavidRad » Mon Mar 26, 2007 10:28 am

Would the cvs update be as follows:

cvs update -r ojs-2_2_0-0

-- OR --

cvs update -r ojs-2_1_1-0


Thanks again!

DavidRad
Posts: 47
Joined: Sun Mar 25, 2007 4:49 pm
Location: Saugerties, NY
Contact:

Errors still exist

Postby DavidRad » Mon Mar 26, 2007 10:35 am

http://24.161.80.157/mhr/ojs2/index.php ... r/register


I replaced ojs2/classes/form/Form.inc.php and cleared caches and still the errors appear.

Thanks

mj
Site Admin
Posts: 304
Joined: Fri Mar 26, 2004 9:32 am
Location: Toronto, Canada
Contact:

re: Errors still exist

Postby mj » Mon Mar 26, 2007 11:59 am

Hi David,

Are you certain that you're using the latest version (1.18) of the Form.inc.php file (filesize: 5657 bytes)? The errors disappear on my install, and arrays shouldn't be passed to the transcoder in the fixed version. Have a look at: http://pkp.sfu.ca/cvs/cvsweb.cgi/ojs2/classes/form/

MJ Suhonos
OJS Development Team

DavidRad
Posts: 47
Joined: Sun Mar 25, 2007 4:49 pm
Location: Saugerties, NY
Contact:

Still no cigar

Postby DavidRad » Mon Mar 26, 2007 1:32 pm

You were right. For some reason I hadn't made the change, though when replaced with the corrected v 1.8 version I still get errors:

http://24.161.80.157/mhr/ojs2/index.php ... r/register

There's less errors though one still exists.

Thanks for your help :-)

mj
Site Admin
Posts: 304
Joined: Fri Mar 26, 2004 9:32 am
Location: Toronto, Canada
Contact:

re: Errors still exist

Postby mj » Mon Mar 26, 2007 2:48 pm

Hi David,

The warning you're still getting is coming from a bit of extra whitespace after the closing php tag (a blank line) -- I've taken it out and it'll go into my next CVS commit, for now to fix it you can just do the same.

Glad to be able to help, and thanks again for reporting the bug.

MJ Suhonos
OJS Development Team

DavidRad
Posts: 47
Joined: Sun Mar 25, 2007 4:49 pm
Location: Saugerties, NY
Contact:

Thanks!

Postby DavidRad » Mon Mar 26, 2007 3:11 pm

That was it! Thanks again.


Return to “OJS Technical Support”

Who is online

Users browsing this forum: No registered users and 3 guests