404 errors for "How to cite item" and other tools

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.
Posts: 3
Joined: Mon Jan 29, 2007 10:41 am
Location: Charlottesville, VA

404 errors for "How to cite item" and other tools

Postby bess » Mon Jan 29, 2007 11:31 am

We are using OJS and we are just in the process of moving some of our journals over to it. Mostly it is working very well, but when viewing an individual article, several of the links on the right side of the page give 404 errors. These links are "How to cite item", "Indexing metadata", "Print version", ... well, all of them except "Review policy" and "Add comment."

OJS is running on RedHat Linux, apache httpd 2.0.52, with mysql v. 4.1.20, and php v. 4.3.9.

404 usually means a missing file, so I checked my httpd logs and they weren't too useful, even after I turned logging up to "debug" level:
[client] OJS: 404 Not Found, referer: http://francesca.lib.virginia.edu/ojs/i ... ewRST/1/26

There must be some way to decipher this so I can track down the problem, but so far I'm coming up blank. Has anyone else run into this? I'm new to OJS. Where should I start looking?

Thanks in advance,

Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm

Postby asmecher » Mon Jan 29, 2007 1:23 pm

Hi Bess,

See http://pkp.sfu.ca/support/forum/viewtopic.php?t=1539 for more information and a fix.

Alec Smecher
Open Journal Systems Team
Don't miss the First International PKP Scholarly Publishing Conference
July 11 - 13, 2007, Vancouver, BC, Canada

Posts: 3
Joined: Mon Jan 29, 2007 10:41 am
Location: Charlottesville, VA

hooray, it worked!

Postby bess » Mon Jan 29, 2007 2:22 pm

Thanks, Alec. That did the trick.
Here's what I did, for the benefit of future readers:
1. On OJS installation, go to $OJS_HOME/pages/rt
2. Open RTHandler.inc.php and see what version is listed in the $Id line. Mine, for example, was v. 1.35
3. Go to http://pkp.sfu.ca/cvs/cvsweb.cgi/ojs2/p ... 36;r2=1.37 (the link provided in Alec's message) but edit the url so that the version number of the first number is the same as the version number of YOUR file. For example, I had to edit the url to this (replacing the 1.36 with 1.35)
http://pkp.sfu.ca/cvs/cvsweb.cgi/ojs2/p ... 35;r2=1.37
4. Copy the whole page and paste it into a file on the server where you have OJS.
5. patch the RTHandler.inc.php like this:
patch RTHandler.inc.php /path/to/patchfile

That's what worked for me.

Return to “OJS Technical Support”

Who is online

Users browsing this forum: No registered users and 4 guests