Quick Submit doesn't recognize File Type (OJS 2.3.7)

Are you an Editor, Author, or Journal Manager in need of help? Want to talk to us about workflow issues? This is your forum.

Moderators: jmacgreg, michael, vgabler, John

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.
Posts: 2
Joined: Wed Sep 19, 2012 5:01 am

Quick Submit doesn't recognize File Type (OJS 2.3.7)

Postby mikokapow » Thu Jan 24, 2013 12:46 am


I've been using the Quick Submit Plugin to quickly upload back issues. I seem to have a problem where the resulting articles have galley files, but their labels are "Untitled" and File Type is listed as "0", instead of automatically being recognized as PDF's with file type: application/pdf.

I've tried renaming the labels to "PDF" so that it appears better on Tables of Contents, but then clicking on the link simply leads to a direct download and not the pdf viewer of OJS.

Is their a configuration or setting i'm missing so that Quick Submit automatically recognizes my pdfs as such?

many thanks!

Posts: 21
Joined: Wed Jul 25, 2007 2:38 am

Re: Quick Submit doesn't recognize File Type (OJS 2.3.7)

Postby ang2el » Thu Mar 21, 2013 9:23 pm

Upgrade to 2.4.2 and if you still see same error, then do the following

1. Go to the Issue (if you have already published it)

2. Then go to articles

3. go to "Editing"

4. Click "edit" in Galley Format

5. There you change "PDF from "Untitled"

At least this will serve to some extent to show link to PDF instead of Untitled, it will download PDF instantly without view.

Hope it is helpful.

Return to “OJS Editorial Support and Discussion”

Who is online

Users browsing this forum: No registered users and 2 guests