Installation process does not even start

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
The Public Knowledge Project Support Forum is moving to

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.

Installation process does not even start

Postby bartneck » Thu Aug 31, 2006 7:19 pm


I followed the steps described in the README and when i call index.php i get this error message:

(mysql): SELECT * FROM journals WHERE path = 'indexphp'

Warning: mysql_query(): supplied argument is not a valid MySQL-Link resource in /homepages/10/d20092181/htdocs/hri/lib/adodb/drivers/ on line 488

2002: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)

I have not even entered any information and i did not edit the database section in the file. What am i doing wrong?

Thank you for your help


Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm

Postby asmecher » Sat Sep 02, 2006 12:00 am

Hi Bartneck,

Check that your MySQL server is running -- that message indicates that OJS is having trouble connecting. If you haven't performed the installation yet, ensure also that the Installed option is set to Off in before continuing.

Alec Smecher
Open Journal Systems Team


problem solved

Postby bartneck » Sat Sep 02, 2006 12:33 am

Thank you for the suggestion. It turned out that i was encountering an issue with Mac OS X. Connecting MySQL to PHP through a socket requires a small adjustment in the system's configuration files as described in this document at Apple. I was not even using their server version, but their recommendations solved my problem:

Return to “OJS Technical Support”

Who is online

Users browsing this forum: Yahoo [Bot] and 1 guest