Problem after first install

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
The Public Knowledge Project Support Forum is moving to

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.
Posts: 3
Joined: Sat Jan 12, 2013 1:51 pm

Problem after first install

Postby VelvetSSS » Sat Jan 12, 2013 2:15 pm

Hi all,
I've just successfully installed OJS-2.3.8 on a Debian server.
I say successfully because it was the message I've got finishing install, so I try to log with the account just created during the install procedure...
It always fails with the well known message "Wrong username or password"?

I'm running Apache2 on Debian Squeeze as webserver (development machine: http://localhost/ojs),
mysql Ver 14.14 Distrib 5.1.66, for debian-linux-gnu (x86_64) using readline 6.1
PHP 5.3.3-7+squeeze14 with Suhosin-Patch (cli)-Suhosin v0.9.32.1

I've carrefully tried to redo an install after a purge of the previous one (including database), same issue.

Did I miss some steps or misunderstood something? It seems a so simple install procedure that I can't figure out where I could be wrong.
Any advices, suggestions will be very welcome, thanks in advance.


Site Admin
Posts: 910
Joined: Tue Jan 10, 2006 6:20 am

Re: Problem after first install

Postby JasonNugent » Mon Jan 14, 2013 6:36 am

Hi there,

What encryption setting did you use for your passwords? OJS can use either md5 or sha1, but the latter may not be installed on all PHP versions. It'd be in your file as the "encryption" parameter.


Posts: 3
Joined: Sat Jan 12, 2013 1:51 pm

Re: Problem after first install

Postby VelvetSSS » Mon Jan 14, 2013 11:46 am

sha1, I've already installed and runing a Drupal7, and an OpenPublish (Drupal based) without any problem of this kind.
I first tried OJS-2.3.8, I then clean this one, deleted its MySql ojs base.
I did a new attemp with OJS 2.4.1, same problem, the install process ends successfully, but still I'm unable to log in with 'username' and 'password' previously created.
I've tried to ALTER USER 'username' and 'password' within the base itself of course successfully, but still same issue when trying to log in...
Since my PHP install was suhosin protected, I first try to modify suhosin.config: same issue, I finaly remove suhosin from my config, same issue...
I'm going to install Postgresql in order to do some more tries...
My task is actually to evaluate the best solution for my customer to better suit his own needs between Drupal and OJS...
But he is not using Postgres, he's already runing MySql.

Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm

Re: Problem after first install

Postby asmecher » Mon Jan 14, 2013 11:59 am

Hi VelvetSSS,

I wonder if you're mixing your database username/password (used to connect to MySQL or PostgreSQL) with your administrator's username/password (used to login to OJS, and stored in the "users" table in the database). The two are unrelated. Note that you can reset your admin password by following these directions.

Alec Smecher
Public Knowledge Project Team

Posts: 3
Joined: Sat Jan 12, 2013 1:51 pm

Re: Problem after first install

Postby VelvetSSS » Mon Jan 14, 2013 1:54 pm

I've now set up couple servers running on two different machines.
One is Apple hardware runing Debian squeeze (no more MacOS X) with Postgres only.
The other one is an Intel based Dell hardware also runing Debian but with MySQL only.
Drupal7 and OP are both installed and working on these platforms wich are devlopment ones.

To be as clear as possible:
On the Dell, I open my browser, go to <localhost/drup> or <localhost/op>. Both drup and op dir are located in /var/www.
it works as it is supposed to do.

For my OJS install, i've just created a new dir called ojs in /var/www, move the uncompressed content of ojs dir to that location, carrefully followed the installation processs as described in the readme file
(let the installer to create the database).
I've of course got the successfully installed page inviting to log in... (url is as expected <http://localhost/ojs/index.php/index/login>)
Then you know the story... right name, right password but I can't log in.
So I configured SMTP within, the click the 'forgot youtr password' button...
I received:
We have received a request to reset your password for the Open Journal
Systems web site.

If you did not make this request, please ignore this email and your password
will not be changed. If you wish to reset your password, click on the below

Reset my password:
http://localhost/ojs/index.php/index/lo ... irm=b23f70

Open Journal Systems

Follow the procedure, receive a new mail :
Your password has been successfully reset for use with the Open Journal
Systems web site. Please retain this username and password, as it is
necessary for all work with the journal.

Your username: THE_USER_NAME
Your new password: xxxxxxxx

Open Journal Systems

Follow the procedure.... The current password is always wrong!!!

Since I'm runing php5, it support sha1 (proposed by default in ojs install page). Cookies are enable in my two browsers: firefox (iceveasel with debian) and chrome.
I'm of course facing same issue with the two browsers (if not I surely wouldn't have post here...).
Each base is created by let's call it the MySQLadmin, GRANTED WITH PRIVILEGE to create bases.
The OJS admin has a different name and password than MySQLadmin, same for the Drupal and OP admins.

I can't spend more time today solving this problem, but I'm planing to try to install OJS on the Apple station to test against a Postgres base.

Thanks for yout interest


Return to “OJS Technical Support”

Who is online

Users browsing this forum: No registered users and 2 guests