upgrade

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.
lhansard
Posts: 2
Joined: Mon Aug 21, 2006 11:31 am
Contact:

upgrade

Postby lhansard » Mon Aug 21, 2006 11:36 am

I'm getting this error when I try to upgrade:

patch -p1 < ojs-2.1.0-1_to_2.1.1.patch
Looks like a unified context diff.
File to patch:

Am I doing something wrong?

Thanks

asmecher
Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm
Contact:

Postby asmecher » Wed Aug 23, 2006 6:04 am

Hi lhansard,

You may be attempting to apply the patch in the wrong directory. Are you in your OJS base directory (i.e. the directory with index.php in it)? Also try passing the -u option to patch.

Regards,
Alec Smecher
Open Journal Systems Team

jugriffin
Posts: 12
Joined: Wed Aug 16, 2006 12:32 pm
Contact:

Postby jugriffin » Thu Aug 24, 2006 12:31 pm

Hi Alec, we went with a reinstall (rather than the patch) from 2.1.0.1 to 2.1.1 and everything went fine - except that all users will have to reset their password the next time they log in.

I'm wondering if the password reset is something to expect with the patch upgrade too. I'd like to avoid it if at all possible! If it doesn't then we'll try it again.

--Julie

asmecher
Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm
Contact:

Postby asmecher » Thu Aug 24, 2006 2:32 pm

Hi Julie,

You shouldn't need to ask users to reset their passwords using either method. Is it possible that you're using a different hashing method with your new installation -- e.g. MD5 vs. SHA1? Check your config.inc.php configuration file and try the other hashing method.

Regards,
Alec

jugriffin
Posts: 12
Joined: Wed Aug 16, 2006 12:32 pm
Contact:

Postby jugriffin » Wed Aug 30, 2006 5:21 am

Hi Alec,

Thank you for your help. We tried a different hashing method and problem solved!

Julie


Return to “OJS Technical Support”

Who is online

Users browsing this forum: No registered users and 3 guests