Invalid Return-Path in email header

Are you responsible for making OCS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, michael, John

Forum rules
The Public Knowledge Project Support Forum is moving to

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.
Posts: 23
Joined: Fri Aug 15, 2008 7:33 am

Invalid Return-Path in email header

Postby igotea » Sun Jan 10, 2010 9:53 am


my OCS instance in combination with Postfix send the mails ok, but not
every one receive them.

I observed that the header of messages sent from the OCS email forms
have a wrong Return-Path, like:

Searching for a solution, I observed that if I modify the php.ini
file by adding:

Code: Select all

    sendmail_path = /usr/sbin/sendmail -t -i -f

the message will reach the final destination.

The questions:
- what changes to make to have the return-path adress equal whith the "from adress" ?
- Is the OCS mail () form wrong or I must work on my php.ini file ?


Last edited by igotea on Wed Jul 27, 2011 11:23 pm, edited 1 time in total.

Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm

Re: Invalid Return-Path in email header

Postby asmecher » Thu Jan 14, 2010 8:20 pm

Hi Ionut,

Two things to try:
1) Try enabling the "allow_envelope_sender" option in and setting the "default_envelope_sender" setting to a reasonable default (i.e. your installation's primary contact).

2) Try using SMTP mailing rather than your local MTA. (See the [email] section in for details on this.)

Alec Smecher
Public Knowledge Project Team

Posts: 33
Joined: Mon Jul 13, 2009 1:07 pm

Re: Invalid Return-Path in email header

Postby JerryRice » Wed Feb 23, 2011 1:14 pm

We had the same issue on OJS over here.

Things have always worked fine and people received emails no problem until recently.
I implemented the allow_envelope_sender = On (took off the ; from the beginning of the line) and changed the default_envelope_sender to a valid email and emails are getting through now.

Return to “OCS Technical Support”

Who is online

Users browsing this forum: No registered users and 1 guest