Strange Fault Error On Attempt to Publish to OJS

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.
ojshelpatucalgary
Posts: 10
Joined: Fri Feb 08, 2013 4:14 pm
Location: Calgary

Strange Fault Error On Attempt to Publish to OJS

Postby ojshelpatucalgary » Fri Feb 08, 2013 6:43 pm

We are experiencing a strange error being thrown when attempting to publish an issue to a journal that had been working fine in this regard.
The only change that has been made recently is the IP address and DNS settings to the VM where the journal is hosted.
What's most weird is the error references java and WIN.

Array ( [faultcode] => soapenv:Server.userException [faultstring] => java.lang.StringIndexOutOfBoundsException: String index out of range: -4 [detail] => Array ( [hostname] => WIN-NNDXTZZKCBH ) )
Fault

Could this be coming from something external to OJS, like Apache?

Thanks for any help to figure this out.

asmecher
Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm
Contact:

Re: Strange Fault Error On Attempt to Publish to OJS

Postby asmecher » Fri Feb 22, 2013 5:41 pm

Hi ojshelpatucalgary,

Sorry, I'm not sure where that's coming from -- but it's definitely not OJS.

Regards,
Alec Smecher
Public Knowledge Project Team

ojshelpatucalgary
Posts: 10
Joined: Fri Feb 08, 2013 4:14 pm
Location: Calgary

Re: Strange Fault Error On Attempt to Publish to OJS

Postby ojshelpatucalgary » Fri Feb 22, 2013 7:58 pm

I should have mentioned here that we figured out that it was a problem with our PID PlugIn connection to our handle server and generating PID's.
Nothing to do with OJS itself. It's been sorted out now.

Thanks!


Return to “OJS Technical Support”

Who is online

Users browsing this forum: No registered users and 4 guests