Upgrade to OJS 3.4.3 - urls appended with %5C

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.
rootl
Posts: 62
Joined: Wed Feb 20, 2013 7:17 am

Upgrade to OJS 3.4.3 - urls appended with %5C

Postby rootl » Wed Feb 12, 2014 8:52 am

Greetings:

We are running Apache 2.4.2 on Windows 2008 server (yes I know, not ideal)

On our development server,I upgraded from OJS 2.4.2 to 2.4.3 without an issue.

On our live server, the upgrade resulted in "%5C" appended to all urls resulting in the site not loading properly. I have checked the config file, the database for any backslashes. I cleared the caches. I have not had problems upgrading from previous versions in the past.

I do see in the database the below query
SELECT *
FROM `ojs`.`plugin_settings`
WHERE (
CONVERT( `plugin_name`
USING utf8 ) LIKE '%\\\\%'
OR CONVERT( `locale`
USING utf8 ) LIKE '%\\\\%'
OR CONVERT( `journal_id`
USING utf8 ) LIKE '%\\\\%'
OR CONVERT( `setting_name`
USING utf8 ) LIKE '%\\\\%'
OR CONVERT( `setting_value`
USING utf8 ) LIKE '%\\\\%'
OR CONVERT( `setting_type`
USING utf8 ) LIKE '%\\\\%'
)
LIMIT 0 , 30

Any ideas? Thanks!

asmecher
Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm
Contact:

Re: Upgrade to OJS 3.4.3 - urls appended with %5C

Postby asmecher » Wed Feb 12, 2014 9:04 am

Hi rootl,

Try patching bug #8014, listed at http://pkp.sfu.ca/wiki/index.php/OJS_2.4.3_Recommended_Patches.

Regards,
Alec Smecher
Public Knowledge Project Team

rootl
Posts: 62
Joined: Wed Feb 20, 2013 7:17 am

Re: Upgrade to OJS 3.4.3 - urls appended with %5C

Postby rootl » Wed Feb 12, 2014 9:41 am

Yes, that did it. Thank you!


Return to “OJS Technical Support”

Who is online

Users browsing this forum: Yahoo [Bot] and 1 guest