Unable to upload PDF file to "Galley" in Layout, o

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.
Posts: 1
Joined: Tue Jul 11, 2006 2:54 pm
Location: NC State Univ., Raleigh, NC, USA

Unable to upload PDF file to "Galley" in Layout, o

Postby hubbe » Tue Jul 11, 2006 3:10 pm

Dear Support,

In preparing the inaugural issue of the new online journal BioResources (http://www.bioresourcesjournal.com), we have encountered a puzzling problem affecting just one of our articles. For some reason the system refuses to accept a PDF file upload to the Galley, while in Layout mode, while we are in the account for that accepted article. We have not had the problem in the case of other accepted articles, including some articles that are longer and more complicated.

We have tried the following strategies in an effort to overcome the problem. In each case we simply get a "Page Not Available" error message after we select the respective PDF file version and then click on the upload command. (a) We have tried to prepare the PDF file from MS WORD using different software, including various versions of Adobe Acrobat Distiller and competing software. (b) We have tried reconstructing the entire article from ASCII text, adding back the needed subscripts, superscripts, and italics, etc. (c) We have subsituted another 5-page PDF file, with the same results.

We WERE able to upload simple PDFs created from MS WORD files that contained only the word "test" or similar short test files.

We have never had a similar problem when dealing with the accounts of other submitted and accepted articles (though we are just at the point of having five articles in our inaugural issue; so that's not much experience to go on).

If anyone has found a way to overcome problems of this nature, we would be very appreciative of your input.

Marty Hubbe
(919) 513-3022

Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm

Postby asmecher » Tue Jul 11, 2006 3:35 pm

Hi Martin,

Have you checked that this file doesn't exceed your configured file size limits as per the Apache or PHP configuration files? From docs/FAQ:
2) Uploads of large files fail inexplicably.

A: This can be caused by certain Apache or PHP settings.

Apache 2.x has a LimitRequestBody directive that, if set to a low number, can
lead to this behaviour. In particular, the default PHP packages for recent
versions of Red Hat Linux set LimitRequestBody to 524288 bytes in

Low values for the PHP ini settings like post_max_size (default "8M"),
upload_max_filesize (default "8M"), and memory_limit (default "8M") can also
cause this problem.
Otherwise, check your server logs to see if any related error messages have been recorded. This might be a file permissions problem; if so, the log should contain more information.

Alec Smecher
Open Journal Systems Team

Return to “OJS Technical Support”

Who is online

Users browsing this forum: No registered users and 2 guests