Problems from 2.2.4 to 2.4.2

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
The Public Knowledge Project Support Forum is moving to

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.
Posts: 2
Joined: Sun Sep 29, 2013 12:21 pm

Problems from 2.2.4 to 2.4.2

Postby rjudd » Sun Sep 29, 2013 12:42 pm

I had to move up from 2.2.4 today because our hosting service no longer permits use of php 5.2, and OJS 2.2.4 won't run in php 5.4.

I tried the 2.2.4 to 2.4.2 patch file but that resulted in many "Hunk" errors and REJ files. Could not locate a way to determine how to resolve this problem in the forum.

Also tried installing 2.4.2 package via that set of instructions.

Currently the site does not locate the issues of the journal. And the OJS version in the "about" page has not been updated. (I know that this means that the upgrade did not complete correctly, but am not sure how to locate and resolve the error.)

Per one forum suggestion, I set the "install" to off in config and tried installing that way; immediate DB error was Table not found: "copyed_assignment". and the install aborted.

I've reset the install and set the debug to on; am not seeing any obvious errors ( I'd really be grateful for assistance! Thanks in advance.

Posts: 2
Joined: Sun Sep 29, 2013 12:21 pm

Re: Problems from 2.2.4 to 2.4.2

Postby rjudd » Sun Sep 29, 2013 5:34 pm

I have read viewtopic.php?f=8&t=10553 on 2.2.4 to 2.4.2 and am stuck.

I'm sure that I should be applying some of the patches, as pointed out, prior to running the db upgrade. But being a newbie to running patches, I am not sure how to do it. So for example: For the patch 0001-Relax-not-null-constraint-on-review_round_id-in-revi.patch

I put it in the ojs top-level directory and ran

Code: Select all

patch p1 < 0001-Relax-not-null-constraint-on-review_round_id-in-revi.patch

And received the error

Hunk #1 FAILED at 58.
1 out of 1 hunk FAILED -- saving rejects to file p1.rej

Other patches are not files per se; bug #8343 opens to file ... 4ee4d.diff, plain text. I do not know how to install that patch at all. (And it would appear to be relevant for me, since I got at "copyed_assignment" db error.)

Is there a Forum or help page for newbies like me for installing the patches? Thanks in advance.

Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm

Re: Problems from 2.2.4 to 2.4.2

Postby asmecher » Mon Sep 30, 2013 10:05 am

Hi Bob,

You're missing a "-" in the patch command -- that parameter should read "-p1" not just "p1". For the plain text URL, you can save that file to disk and apply it like the others.

Alec Smecher
Public Knowledge Project Team

Return to “OJS Technical Support”

Who is online

Users browsing this forum: No registered users and 1 guest