Error on reload locale

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.
newbies
Posts: 87
Joined: Sat Feb 23, 2013 9:15 pm

Error on reload locale

Postby newbies » Sun Aug 04, 2013 1:35 am

Hi All,

version: 2.4.2

I tried to reload locale under site adminstration, and got a blank page with the following error message:

Code: Select all

ojs2 has produced an error Message: WARNING: filemtime() [function.filemtime]: stat failed for /home/jbm/registry/locales.xml In file: /home/jbm/public_html/lib/pkp/classes/i18n/PKPLocale.inc.php At line: 598 Stacktrace: Server info: OS: Linux PHP Version: 5.3.23 Apache Version: N/A DB Driver: mysql DB server version: 5.1.70-cll

ojs2 has produced an error Message: WARNING: Cannot modify header information - headers already sent by (output started at /home/jbm/public_html/lib/pkp/classes/core/PKPApplication.inc.php:392) In file: /home/jbm/public_html/lib/pkp/classes/core/PKPRequest.inc.php At line: 87 Stacktrace: Server info: OS: Linux PHP Version: 5.3.23 Apache Version: N/A DB Driver: mysql DB server version: 5.1.70-cll


Actually, the above message appears on every page if I turn on display_error. What is wrong with my installation and how can I fix it? Thank you for your help.

asmecher
Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm
Contact:

Re: Error on reload locale

Postby asmecher » Sun Aug 04, 2013 9:53 am

Hi newbies,

The file registry/locales.xml is missing from your installation or has file permissions set such that OJS can't read it.

Regards,
Alec Smecher
Public Knowledge Project Team

newbies
Posts: 87
Joined: Sat Feb 23, 2013 9:15 pm

Re: Error on reload locale

Postby newbies » Sun Aug 04, 2013 11:19 am

Hi Alec,

Thank you for replying. the file registry/locales.xml exists, and the setting for the folder is 755 and 644 for the file. Even I change them all to 777, it made no difference.

according to this instruction

Code: Select all

Localization
------------
To add support for other languages, the following sets of XML files must be
localized and placed in an appropriately named directory (using ISO locale
codes, e.g. "fr_FR", is recommended):

   * locale/en_US
   * help/en_US
   * registry/locale/en_US
   * rt/en_US
   * plugins/[plugin category]/[plugin name]/locale, where applicable


en_US folder is missing in the reigstry/locale folder, so I created one. This did not help either.

Attached is a sreenshot of the language setting page.
SP32-20130804-111427.gif
SP32-20130804-111427.gif (36.63 KiB) Viewed 597 times

newbies
Posts: 87
Joined: Sat Feb 23, 2013 9:15 pm

Re: Error on reload locale

Postby newbies » Sun Aug 04, 2013 8:33 pm

OMG, you are right. The file does not exist because the directory is wrong. I left out the www in the path. Now problem solved!


Return to “OJS Technical Support”

Who is online

Users browsing this forum: Yahoo [Bot] and 1 guest