Problem with labels for language select and searchfields

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.
gessy
Posts: 1
Joined: Mon Jun 09, 2014 10:52 am

Problem with labels for language select and searchfields

Postby gessy » Mon Jun 09, 2014 11:10 am

Hi,

i upgrade my ojs from 2.2.3.0 to 2.4.4.1. Everything is ok but there's a problem.
When I set language to english, all interface is fine but when a choose other languange like spanish ir portuguese, the labels for language and search fields only display the codes ##plugins.block.languageToggle.selectLabel## and #plugins.block.navigation.searchScope##.
I already tried reinstall with package downloaded from the official site but nothing changed.
Someone can help me.
Thanks a lot

asmecher
Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm
Contact:

Re: Problem with labels for language select and searchfields

Postby asmecher » Mon Jun 09, 2014 12:07 pm

Hi gessy,

That probably means that these languages are not completely translated. See http://pkp.sfu.ca/wiki/index.php?title=Translating_OxS for information on translating.

Regards,
Alec Smecher
Public Knowledge Project Team

ernesto
Posts: 19
Joined: Tue Dec 16, 2003 11:53 am
Location: Spain
Contact:

Re: Problem with labels for language select and searchfields

Postby ernesto » Tue Aug 12, 2014 5:54 am

asmecher wrote:Hi gessy,
That probably means that these languages are not completely translated. See http://pkp.sfu.ca/wiki/index.php?title=Translating_OxS for information on translating.


Hello and thanks in advance:

We have the same problem with the es_ES locale.

We can not find solution in the link you said. Could you be more precise?

ctgraham
Posts: 240
Joined: Thu Apr 03, 2014 5:29 am
Location: Pitt ULS

Re: Problem with labels for language select and searchfields

Postby ctgraham » Tue Aug 12, 2014 6:14 am

The easiest method is probably to use the Translation plugin:
http://pkp.sfu.ca/wiki/index.php?title=Translating_OxS#Using_the_Translation_Plugin_Tool

Note that a fresh translation is expected with the upcoming release of OJS 2.4.5.

ernesto
Posts: 19
Joined: Tue Dec 16, 2003 11:53 am
Location: Spain
Contact:

Re: Problem with labels for language select and searchfields

Postby ernesto » Tue Aug 12, 2014 7:22 am

ctgraham wrote:The easiest method is probably to use the Translation plugin:
http://pkp.sfu.ca/wiki/index.php?title=Translating_OxS#Using_the_Translation_Plugin_Tool
Note that a fresh translation is expected with the upcoming release of OJS 2.4.5.


Thanks ctgraham:

I solved the problem adding the following line at /plugins/blocks/languageToggle/locale/es_ES/locale.xml

Code: Select all

<locale name="es_ES" full_name="Español (España)">
        <message key="plugins.block.languageToggle.selectLabel">Seleccionar idioma</message>
</locale>


Return to “OJS Technical Support”

Who is online

Users browsing this forum: Yahoo [Bot] and 2 guests