OAI Page error?

Open Harvester Systems support questions and answers, bug reports, and development issues.

Moderators: jmacgreg, michael, John

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.
AndyP
Posts: 57
Joined: Wed Mar 22, 2006 8:21 am
Contact:

OAI Page error?

Postby AndyP » Sat May 03, 2008 4:40 am

http://www.equinoxjournals.com/ojs/index.php/index/oai leads to the xml page below. I guess the error means that this isn't working, any clues?

Thanks

Andy

<?xml version="1.0" encoding="UTF-8" ?>
- <OAI-PMH xmlns="http://www.openarchives.org/OAI/2.0/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://www.openarchives.org/OAI/2.0/ http://www.openarchives.org/OAI/2.0/OAI-PMH.xsd">
<responseDate>2008-05-03T11:34:50Z</responseDate>
<request>http://www.equinoxjournals.com/ojs/index.php/index/oai</request>
<error code="badVerb">Illegal OAI verb</error>
</OAI-PMH>

mj
Site Admin
Posts: 304
Joined: Fri Mar 26, 2004 9:32 am
Location: Toronto, Canada
Contact:

Re: OAI Page error?

Postby mj » Mon May 05, 2008 11:30 am

Hi Andy,

The OAI interface is probably working fine. The way the OAI protocol works, is that it embeds verbs in the HTTP request to your journal. Just hitting the URL in a web browser doesn't include any verbs, hence the message you're seeing. You can learn more about the OAI protocol at: http://www.openarchives.org/OAI/openarchivesprotocol.html

Regards,
MJ

AndyP
Posts: 57
Joined: Wed Mar 22, 2006 8:21 am
Contact:

Re: OAI Page error?

Postby AndyP » Tue May 06, 2008 5:24 am

what's the easiest way to test if the harvester is working?

mj
Site Admin
Posts: 304
Joined: Fri Mar 26, 2004 9:32 am
Location: Toronto, Canada
Contact:

Re: OAI Page error?

Postby mj » Tue May 06, 2008 12:20 pm

Hi Andy,

If you log in as the harvester administrator, you should be able to check and update the status of the archives you're harvesting by going to "Administration > Manage Archives" and click "Manage" next to the archive you're interested in. Clicking "Update Metadata Index" should retrieve all the records from the OAI interface of your archive source (ie. journal).

MJ

jalexsu
Posts: 2
Joined: Thu Oct 23, 2014 7:40 am

Re: OAI Page error?

Postby jalexsu » Thu Oct 23, 2014 7:57 am

Hola a todos, he iniciado con la administración de una revista : http://revistavirtual.ucn.edu.co/index.php/RevistaRyS
El inconveniente es cuando quiero comprobar la salida de OAI (http://revistavirtual.ucn.edu.co/index. ... staRyS/oai) me sale el siguiente mensaje de error:

Code: Select all

Error de lectura XML: contenido incorrecto tras un elemento XML del documento
Ubicación: http://revistavirtual.ucn.edu.co/index.php/RevistaRyS/oai
Número de línea 11, columna 1:<script type="text/javascript">
^


La verdad es un campo desconocido para mí y desconozco como darle solución a este inconveniente
Escucho soluciones
gracias

asmecher
Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm
Contact:

Re: OAI Page error?

Postby asmecher » Thu Oct 23, 2014 8:52 am

Hola jalexsu,

This is caused by a modification to your installation involving phpMyVisites and Google Analytics. Ask your administrator to check and fix the modification.

Regards,
Alec Smecher
Public Knowledge Project Team


Return to “Open Harvester Systems Support and Development”

Who is online

Users browsing this forum: No registered users and 1 guest