Problem : Unknown indexing method

Open Harvester Systems support questions and answers, bug reports, and development issues.

Moderators: jmacgreg, michael, John

Forum rules
The Public Knowledge Project Support Forum is moving to

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.
Posts: 3
Joined: Thu Feb 08, 2007 5:13 am
Location: France

Problem : Unknown indexing method

Postby sklima » Thu Feb 08, 2007 5:49 am


I installed the last version of PKP Open Archives Harvester (2.0.1). The installation was succesful.

I add an archive and save it, the navigator downloads an empty file named by "updateArchive...". There are no erros, but is it normal?

Then, when i tried to update Metadata index from archive, i obtained the error (Fatal error : Allowed memory size ... Unknown indexing method). So i increase the PHP memory limit. I set this properties to 64M. I tried again the update of index, and i obtain always "Unknown indexing method" without this time the fatal error, but there are still not records in archive.

Has someone an idea on my problem?

Thanks in advance.

Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm

Postby asmecher » Thu Feb 08, 2007 10:29 am

Hi sklima,

It looks like the indexing method setting for the OAI repository (i.e. listrecords vs. listidentifiers) is not set. In the admin interface, edit and save the archive; this should correct the problem. It may have been caused by the out-of-memory error you mentioned earlier.

Alec Smecher
Public Knowledge Project Team
Don't miss the First International PKP Scholarly Publishing Conference
July 11 - 13, 2007, Vancouver, BC, Canada

Return to “Open Harvester Systems Support and Development”

Who is online

Users browsing this forum: No registered users and 3 guests