Moving OCS-Database

Are you responsible for making OCS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, michael, John

Forum rules
The Public Knowledge Project Support Forum is moving to

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.
Posts: 11
Joined: Wed Dec 19, 2012 3:11 am

Moving OCS-Database

Postby pilone » Mon Mar 18, 2013 10:08 am

Hi everyone,

I just tried to move my OCS-Installation from one Server to another. My strategy was: 1. move all the files as they are, 2. reconfigure config-file and 3. export and import Database to the new Server.

Now what I get, every time I try to load the side on the new Server ist "DB Error: Duplicate entry 'someverylongstringmumbojumbo' for key 'sessions_pkey'".

I already found out, that there is a file called commons.xml where is said, that this should be unique. I'm not sure if I should hotfix this by just commenting that out. Does anyone have an idea what the technical reason for this error is and how I can fix it? Can i just empty the table "sessions"? I tried deleting the entry where "seesion_id" is 'someverylongstringmumbojumbo', which makes the site visible for one time. After that, the error is back and it seems like the session_id used this time is exactly the same as before.

Hope someone can help me. If you need any more clues, I will deliver. But at the moment I don't know exactly what would be useful.

Best Regards,

Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm

Re: Moving OCS-Database

Postby asmecher » Mon Mar 18, 2013 10:36 am

Hi Stephan,

See e.g. and the linked bug entry.

Alec Smecher
Public Knowledge Project Team

Posts: 11
Joined: Wed Dec 19, 2012 3:11 am

Re: Moving OCS-Database

Postby pilone » Tue Mar 19, 2013 3:10 am

Hi Alec,

I deleted the old content of the table and raised the maximum length of session_id to 80. Seems to have done the job.


Return to “OCS Technical Support”

Who is online

Users browsing this forum: No registered users and 2 guests