SOLVED: Upgrading from to 2.3.4 issue

Are you responsible for making OCS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, michael, John

Forum rules
The Public Knowledge Project Support Forum is moving to

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.
Posts: 14
Joined: Wed Nov 02, 2011 3:10 am

SOLVED: Upgrading from to 2.3.4 issue

Postby johnkperks » Wed Nov 02, 2011 3:36 am


Following this post (viewtopic.php?f=8&t=3779), I tried to upgrade my OCS installation from to 2.3.4 and have got the following error when running the patch.

patching file classes/admin/form/
Assertion failed hunk, file ../patch-2.5.9-src/patch.c line 354

This application has requested the Runtime to terminate it in an unusual way.
Please contact the application's support team for more information.

First of all, I am a noob on this upgrading issue. So, here is what I did.

1. Installed XAMPP on my PC
2. Downloaded the OCS installation (in a .zip file) from my server and extracted it in htdocs folder of xampp.
3. Downloaded database file from server and imported it in phpmyadmin via the import function.
4. Changed the username and password so I can get the database connected
5. Checked that the site was working on my localhost by loggin in as admin
6. Downloaded the WinGNU file from ... e/download.
7. Downloaded the WinGNU from the post mentioned at first (viewtopic.php?f=8&t=3779) and dropped the patch.exe file in the root of the OCS folder
8. Extracted the OCS 2.3.4 patch and dropped it in root of the OCS folder and changed its name to anyName.patch
9. Started cmd.exe and went to the root folder
10. Now I tried the following commands:

Code: Select all

patch -p1 --dry-run < anyName.patch

Code: Select all

patch -p1 < anyName.patch

However, I get the error mentioned above at the start of this post.

Reading some other posts, I decided to use the --binary command in the above both codes.

Code: Select all

patch -p1 --dry-run --binary < anyName.patch

Code: Select all

patch -p1 --binary < anyName.patch

In both these cases, a long list of patching files went through. However, as suggested on this post (viewtopic.php?f=3&t=7987) when I went to site administrator > system information, the current version remains

Can you suggest what am I doing wrong and how can it be corrected?

Following asmecher suggestion, I realised that I hadn't performed the 2nd part of the task. Thus, the following steps solved the issue.

11. Opened the file and changed the line "installed = on" to "installed = Off".
12. Now went to the webaddress (in my case http://localhost/ocs) and it suggested the need to upgrade.
12. Click on the upgrade button and after waiting for about a minute of so, VOILA, the upgrade went through.
13. Changed the line "installed = On" again.

This may help noob's like me to go through the process step by step.
Last edited by johnkperks on Wed Nov 02, 2011 2:16 pm, edited 1 time in total.

Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm

Re: Upgrading from to 2.3.4 issue

Postby asmecher » Wed Nov 02, 2011 8:38 am

Hi johnkperks,

The assertion problem is described at; using the --binary option is a good work-around.

With the code updated you're only halfway through the upgrade process; review docs/UPGRADE for instructions on upgrading the database.

Alec Smecher
Public Knowledge Project Team

Return to “OCS Technical Support”

Who is online

Users browsing this forum: No registered users and 1 guest