DB Error upgrading from OCS 2.1.2-1 to 2.3

Are you responsible for making OCS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, michael, John

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.
Posts: 4
Joined: Tue Jan 12, 2010 9:37 am

DB Error upgrading from OCS 2.1.2-1 to 2.3

Postby raphael » Wed Jan 27, 2010 9:57 am

I tried to ugrade OCS from 2.1.2-1 to 2.3 with

Code: Select all

patch -p1 < ocs-2.1.2-1_to_2.3.patch

Patching went OK.

Then upgrading DB with

Code: Select all

php tools/upgrade.php upgrade

gave this error :

Code: Select all

[load: upgrade.xml]
[schema: lib/pkp/xml/schema/common.xml]
[schema: lib/pkp/xml/schema/groups.xml]
[schema: lib/pkp/xml/schema/announcements.xml]
[schema: lib/pkp/xml/schema/controlledVocab.xml]
[schema: lib/pkp/xml/schema/scheduledTasks.xml]
[schema: lib/pkp/xml/schema/temporaryFiles.xml]
[schema: dbscripts/xml/ocs_schema.xml]
[data: dbscripts/xml/upgrade/2.3.0_update.xml]
ERROR: Upgrade failed: DB: Champ 'assoc_type' inconnu dans field list

in english : field 'assoc_type' unknown in field list

I found 'assoc_type' in my OCS DB in tables ending with *_event_log but i don't know what to do to correct this DB error...

Does anybody have an idea of what to do ?

thank you,


Posts: 952
Joined: Mon May 05, 2008 10:29 am
Location: Vancouver, BC

Re: DB Error upgrading from OCS 2.1.2-1 to 2.3

Postby mcrider » Wed Feb 03, 2010 11:26 am

Hi Raphael,

I just attempted this upgrade and it worked fine. I'm concerned maybe the patch didn't work properly, in which case I would suggest trying the 'Full package' upgrade method detailed in docs/UPGRADE. Also, was your OCS 2.1.2 upgraded from a previous version?


Posts: 4
Joined: Tue Jan 12, 2010 9:37 am

Re: DB Error upgrading from OCS 2.1.2-1 to 2.3

Postby raphael » Thu Feb 04, 2010 1:59 am

Thank you for your reply Matt,

I didn't upgraded OCS but i applied the Patch against OCS 2.1.2 mentionned it this bug report :

Patch details :
http://pkp.sfu.ca/bugzilla/attachment.c ... ction=edit

And I am almost sure this is why it didn't work as expected. I'll try the 'Full package' upgrade, if it doesn't work I think i will come back to a vanilla OCS 2.1.2 and then upgrade again with the upgrade patch. I might also restore only the patches files from a vanilla OCS.

I'll try that and report successfull attempts in case someone followed my upgrade path.


Return to “OCS Technical Support”

Who is online

Users browsing this forum: No registered users and 1 guest