DB Error null "currency_code_alpha"

Are you responsible for making OCS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, michael, John

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.
swj
Posts: 3
Joined: Mon Nov 09, 2009 3:12 pm

DB Error null "currency_code_alpha"

Postby swj » Mon Nov 09, 2009 3:24 pm

Can someone please give suggestions on how to fix the 'Create New Registration Option'' in the current stable version (clean install)?

from '.../manager/createRegistrationOption' I click save and then receive the following error from this page, '.../manager/updateRegistrationOption'...

OCS: DB Error: Field 'currency_code_alpha' doesn't have a default value

OCS Version installed: 2.1.2 Current Release (July 19, 2009)

Thanks!

mcrider
Posts: 952
Joined: Mon May 05, 2008 10:29 am
Location: Vancouver, BC

Re: DB Error null "currency_code_alpha"

Postby mcrider » Wed Nov 11, 2009 12:06 pm

Hi swj,

Could you turn on the show_stacktrace and ddebug options in config.inc.php and get back to us with the resulting output after trying to do this again?

Cheers,
Matt

swj
Posts: 3
Joined: Mon Nov 09, 2009 3:12 pm

Re: DB Error null "currency_code_alpha"

Postby swj » Wed Nov 11, 2009 9:10 pm

Hi Matt, thanks for the reply.

I turned (On) show_stacktrace and the two debug options in config.inc.php. Every page displayed information except this page (.../manager/updateRegistrationOption)

Its a white page with the following error:

'OCS: DB Error: Field 'currency_code_alpha' doesn't have a default value'


I tried it from the server and from my laptop

The same behavior exists on versions 2.1.2.0 and 2.1.2.1

Any other suggestions?

asmecher
Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm
Contact:

Re: DB Error null "currency_code_alpha"

Postby asmecher » Wed Nov 18, 2009 7:52 am

Hi swj,

Remove the currency_code_alpha column from the registration_options table; it's not used and is causing this problem. (This is part of bug 4494 at http://pkp.sfu.ca/bugzilla/show_bug.cgi?id=4494.)

Regards,
Alec Smecher
Public Knowledge Project Team

swj
Posts: 3
Joined: Mon Nov 09, 2009 3:12 pm

Re: DB Error null "currency_code_alpha"

Postby swj » Thu Nov 19, 2009 9:22 am

Thanks! I am now able to create registration options.

One other thing, the total is correct when selecting options; however, the invoice (paypal) does not list the names of the options that were added. Is this a bug as well?

thanks again!

asmecher
Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm
Contact:

Re: DB Error null "currency_code_alpha"

Postby asmecher » Fri Nov 20, 2009 2:06 am

Hi swj,

That's currently by design, but you could certainly file a Bugzilla feature request to add more details.

Regards,
Alec Smecher
Public Knowledge Project Team


Return to “OCS Technical Support”

Who is online

Users browsing this forum: No registered users and 1 guest