(RESOLVED in 2.1) Patch userRegistrationForm for multilingue

Are you responsible for making OCS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, michael, John

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.
crihou2
Posts: 22
Joined: Fri May 02, 2008 5:37 am
Location: Lille, France

(RESOLVED in 2.1) Patch userRegistrationForm for multilingue

Postby crihou2 » Mon May 05, 2008 11:16 am

When you have more than one language declared, OCS 2.0.0-1 shows an error message when a user want to register himself.

This patch avoid this problem :

Code: Select all

ocs-2.0.0-1/templates/registration/userRegistrationForm.tpl
line 233
before :   <input {$disableSnippet} type="checkbox" name="userLocales[]" id="userLocales-{$localeKey}" value="{$localeKey}"{if in_array($localeKey, $userLocales)} checked="checked"{/if} /> <label for="userLocales-{$localeKey}">{$localeName|escape}</label><br />

after:       <input {$disableSnippet} type="checkbox" name="userLocales[]" id="userLocales-{$localeKey}" value="{$localeKey}"{if $userLocales == null or in_array($localeKey, $userLocales)} checked="checked"{/if} /> <label for="userLocales-{$localeKey}">{$localeName|escape}</label><br />

Last edited by crihou2 on Fri Jun 06, 2008 1:43 pm, edited 1 time in total.

jmacgreg
Posts: 4191
Joined: Tue Feb 14, 2006 10:50 am
Contact:

Re: Patch userRegistrationForm for multilingue

Postby jmacgreg » Mon May 05, 2008 1:51 pm

Hi crihou2,

Many thanks for the report. I believe this has been fixed in CVS. You can view a specific history for that file here: http://pkp.sfu.ca/cvs/cvsweb.cgi/ocs2/t ... onForm.tpl

In addition, you can view the entire CVS tree for ocs2 from http://pkp.sfu.ca/cvs/cvsweb.cgi/ocs2/.

Again, many thanks,
James

crihou2
Posts: 22
Joined: Fri May 02, 2008 5:37 am
Location: Lille, France

Re: Patch userRegistrationForm for multilingue

Postby crihou2 » Fri May 09, 2008 9:33 am

Hi James

No this bug is not yet report in : http://pkp.sfu.ca/cvs/cvsweb.cgi/ocs2/t ... onForm.tpl

Regards

mj
Site Admin
Posts: 304
Joined: Fri Mar 26, 2004 9:32 am
Location: Toronto, Canada
Contact:

Re: Patch userRegistrationForm for multilingue

Postby mj » Fri May 09, 2008 10:34 am

Hi all,

I assume you're referring to the code that's now in /templates/user/createAccount.tpl (line 180) -- I couldn't seem to find the code you're referring to in /templates/registration/userRegistrationForm.tpl. If you're able to upgrade, when you do so, would you be willing to check this again and fill out a bug report if it still exists?

Thanks,
MJ

crihou2
Posts: 22
Joined: Fri May 02, 2008 5:37 am
Location: Lille, France

Re: Patch userRegistrationForm for multilingue

Postby crihou2 » Wed May 21, 2008 2:27 am

Hy mj

No I haven't seen code but the history file.

I'm not able to upgrade, and I prefer, in this moment, wait the 2.1 version

Regards

crihou2
Posts: 22
Joined: Fri May 02, 2008 5:37 am
Location: Lille, France

Re: Patch userRegistrationForm for multilingue

Postby crihou2 » Fri Jun 06, 2008 11:45 am

Hi

I confirm : This problem doesn't exist any more in OCS 2.1 version.

Regards.


Return to “OCS Technical Support”

Who is online

Users browsing this forum: Bing [Bot] and 2 guests