Registration notification

Are you responsible for making OCS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, michael, John

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.
m.giordano
Posts: 29
Joined: Wed Jan 09, 2008 4:02 am

Registration notification

Postby m.giordano » Mon Jan 21, 2008 11:14 am

Hi all,

provided that we have disabled 'Account' form and link, we only create site accounts by means of the registration form.
But while with the 'Account' page form the subscription notification mail worked properly, in the case of the registration form no mail seems to be sent.

Notice that all other event mails work well.

Any hint?

Regards

Marco

jmacgreg
Posts: 4191
Joined: Tue Feb 14, 2006 10:50 am
Contact:

Re: Registration notification

Postby jmacgreg » Mon Jan 21, 2008 4:00 pm

Hi Marco,

Am I correct in understanding that you are wondering why the system can send out a notification of account registration, but does not provide an email with conference registration confirmation and/or details?

Thanks for the clarification,
James

m.giordano
Posts: 29
Joined: Wed Jan 09, 2008 4:02 am

Re: Registration notification

Postby m.giordano » Mon Jan 21, 2008 4:22 pm

Yes James,

I try to be more precise.
We prefer to use registration form either for conference registration and account creation, that's why we disabled Account page(see http://pkp.sfu.ca/support/forum/viewtopic.php?f=3&t=2440&hilit=#p9394).

Would it be possible to send a notification email with username and password right after the compilation of the registration form, like the Account form does?

Thank you

Marco

jmacgreg
Posts: 4191
Joined: Tue Feb 14, 2006 10:50 am
Contact:

Re: Registration notification

Postby jmacgreg » Tue Jan 22, 2008 3:25 pm

Hi Marco,

OK, I understand now. That should indeed be an option, and I will be reporting it as a feature request for the future. If you'd like to take a crack at it yourself, you can possibly compare what is happening with the standard Account registration page vs. the Account/conference registration page.

Cheers,
James

m.giordano
Posts: 29
Joined: Wed Jan 09, 2008 4:02 am

Re: Registration notification

Postby m.giordano » Tue Jan 22, 2008 3:34 pm

Ok James,

we'll try to hack it mimicking the code from the Account form.
I'll let you know...

Marco

m.giordano
Posts: 29
Joined: Wed Jan 09, 2008 4:02 am

Re: Registration notification

Postby m.giordano » Wed Jan 23, 2008 9:32 am

Hi James,

well done and working.

Marco

jmacgreg
Posts: 4191
Joined: Tue Feb 14, 2006 10:50 am
Contact:

Re: Registration notification

Postby jmacgreg » Wed Jan 23, 2008 1:20 pm

Hi Marco,

Would you be able to provide a patch here for future reference? I submitted a bug/feature request for this (http://pkp.sfu.ca/bugzilla/show_bug.cgi?id=3234), and can run your solution past the developers as well.

Thanks,
James

m.giordano
Posts: 29
Joined: Wed Jan 09, 2008 4:02 am

Re: Registration notification

Postby m.giordano » Thu Jan 24, 2008 10:07 am

Hi James,

I ask Marco Gori (a colleague who has coded the hack) to post a patch proposal directly to the Bugzilla request. Is it o.k. for you?
Consider that we are working on a close deadline, thus the post could come in the forthcoming days....

Cheers

Marco

jmacgreg
Posts: 4191
Joined: Tue Feb 14, 2006 10:50 am
Contact:

Re: Registration notification

Postby jmacgreg » Thu Jan 24, 2008 10:18 am

Hi Marco,

Yes, posting directly to Bugzilla would be appreciated -- go for it.

Cheers,
James

spatialguru
Posts: 112
Joined: Mon Jun 25, 2007 1:23 pm
Location: British Columbia, Canada
Contact:

Re: Registration notification

Postby spatialguru » Thu Feb 21, 2008 3:28 pm

jmacgreg wrote:Would you be able to provide a patch here for future reference? I submitted a bug/feature request for this (http://pkp.sfu.ca/bugzilla/show_bug.cgi?id=3234), and can run your solution past the developers as well.


I've also tried to backport the patch that was posted to that bug, so it would work on 2.0.0.1 - I would appreciate knowing if it works for others.

Tyler


Return to “OCS Technical Support”

Who is online

Users browsing this forum: No registered users and 1 guest