translation: Track

Are you responsible for making OCS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, michael, John

Forum rules
The Public Knowledge Project Support Forum is moving to

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.
Posts: 945
Joined: Wed Oct 15, 2003 6:15 am
Location: Brasí­lia/DF - Brasil

Re: translation: Track

Postby ramon » Thu Sep 27, 2007 10:54 am


Mostly HTML tags and some examples are getting cut off.
When I noticed this I checked the file but most where still there.
The translator is still not showing the full content somehow.

One that is cut off in the interface is admin.conference.importPathInstructions key, which has parentheses, slashes and quotes in it.

Another key was comments.inResponseTo cutting exactly after the fisrt = sign

It cut off after the beginining of the second CDATA, for comments.inResponseTo key.
Looking at the file, here's the error:

Code: Select all

<![CDATA[Em resposta a <a href=]]>

What it should be:

Code: Select all

Em resposta a <![CDATA[<a href="]]>{$url}<![CDATA[">]]>{$title}<![CDATA[</a>]]>

Couldn't find any more errors for now...

But I think I know what happened.

I am copying and pasting some of the translations already done for OJS and making the necessary changes. I think I copied and pasted the key comments.inResponseTo with the CDATA tags withing the field. I assume the translator converts HTML tags automatically, adding the CDATA sections.

After I manually corrected it, the translator is still not able to display the content correctly, but the content is there... If I save the form, it will probably create an error.
Last edited by ramon on Thu Sep 27, 2007 11:28 am, edited 1 time in total.

Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm

Re: translation: Track

Postby asmecher » Thu Sep 27, 2007 11:25 am

Hi Ramón,

Are you entering <![CDATA[ .. ]]> segments into the translator plugin's text boxes? The plugin should take care of CDATA escaping by itself; this could explain the problem.

Alec Smecher
Public Knowledge Project Team

Return to “OCS Technical Support”

Who is online

Users browsing this forum: No registered users and 1 guest