Cache-Control | max-age=172800?

Are you responsible for making OCS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, michael, John

Forum rules
The Public Knowledge Project Support Forum is moving to

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.
Posts: 22
Joined: Wed May 02, 2012 1:16 pm

Cache-Control | max-age=172800?

Postby Jim » Fri May 31, 2013 3:02 pm

OCS version - PHP5.2.6-1+lenny9 - Apache2

I'm troubleshooting a caching problem. I'd like to disable caching temporarily and or change some settings.

In the http response header I see this line Cache-Control max-age=172800. Where does this come from, the Apache2 config or the PHP config? I'd like to turn if off, or set it to 3600.

Also how do you turn off caching? We're using x-cache. Can I simple edit the php.ini file and set the local and master values for xcacher.cacher to off?


Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm

Re: Cache-Control | max-age=172800?

Postby asmecher » Fri May 31, 2013 3:15 pm

Hi Jim,

The max-age and XCache parts of your question are outside of anything OCS has control over; XCache can be disabled by editing php.ini and restarting apache, but you're best off googling for details. The max-age default could be coming from PHP or Apache; again, some googling should turn it up. OCS doesn't specify the max-age parameter, but it does control caching type; search lib/pkp/classes/template/ for Cache-Control to find where that happens.

Alec Smecher
Public Knowledge Project Team

Posts: 22
Joined: Wed May 02, 2012 1:16 pm

Re: Cache-Control | max-age=172800?

Postby Jim » Fri May 31, 2013 7:35 pm

Thanks Alex.

Return to “OCS Technical Support”

Who is online

Users browsing this forum: No registered users and 1 guest