Harvesting our journal

Are you an Editor, Author, or Journal Manager in need of help? Want to talk to us about workflow issues? This is your forum.

Moderators: jmacgreg, michael, vgabler, John

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.
helenw
Posts: 18
Joined: Thu Dec 09, 2004 9:31 pm
Location: Swinburne University of Technology, Melbourne, Australia

Harvesting our journal

Postby helenw » Sun Aug 21, 2005 8:50 pm

Dear OJS users,

We're wanting to have our journal (http://ojs.lib.swin.edu.au/index.php/ejap) harvested by the ARROW National Discovery Service http://search.arrow.edu.au but we've struck a problem.

We've been told that we need to generate an 'until parameter' in order to be harvested.

Our journal is currently being harvested by the PKP Open Archives Harvester and OAIster without any problems - maybe OAIster and PKP Harvesters put in a default value for us, I don't know.

If anyone out there knows more about this could you please let me know...

Thanks in advance,

Helen Wolff

kevin
Posts: 338
Joined: Tue Oct 14, 2003 8:23 pm
Contact:

Postby kevin » Sun Aug 21, 2005 10:38 pm

I'm not sure what they're referring to by "until parameter", at least in the context of something generated by the archive.

The only "until parameter" specified by the OAI protocol are arguments passed to the ListRecords or ListIdentifiers requests by a harvester.

smcphill

what is meant by "until"

Postby smcphill » Mon Aug 22, 2005 6:07 pm

Hi Kevin,

I'm the sys. admin for the discovery service Helen is talking about. The problem we are experiencing is that the OJS repository returns no results for a valid 'until' parameter with a ListRecords action. See the following as an example:

http://ojs.lib.swin.edu.au/index.php/ej ... fix=oai_dc

http://ojs.lib.swin.edu.au/index.php/ej ... fix=oai_dc

thoughts? I had a quick look at the classes/oai/OAI.inc.php which shows from and until are handled the same, so I'm guessing the problem isn't with the OAI interface, but perhaps the internal ojs / oai bridge? (of course, I've only spent 10 minutes looking at this issue, so don't really know what I'm talking about :)

kevin
Posts: 338
Joined: Tue Oct 14, 2003 8:23 pm
Contact:

Postby kevin » Mon Aug 22, 2005 9:21 pm

Your archive doesn't appear to be using either the from or until parameters correctly. If you are not using 2.0.1 then this bug is the problem.

helenw
Posts: 18
Joined: Thu Dec 09, 2004 9:31 pm
Location: Swinburne University of Technology, Melbourne, Australia

Postby helenw » Wed Aug 24, 2005 5:10 pm

Hi Kevin, we're using OJS 2.0.1 for our journal. Do you have any other ideas as to what the problem might be?

Helen

kevin
Posts: 338
Joined: Tue Oct 14, 2003 8:23 pm
Contact:

Postby kevin » Wed Aug 24, 2005 7:37 pm

On closer inspection it appears that the date handling bugs were not corrected in all cases until 2.0.2.


Return to “OJS Editorial Support and Discussion”

Who is online

Users browsing this forum: No registered users and 5 guests