failed to open stream: Invalid argument

General inquiries about the PKP.

Moderators: jmacgreg, btbell, michael, bdgregg, vgabler, barbarah, John

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.
msbarc
Posts: 2
Joined: Wed Mar 12, 2014 9:19 pm

failed to open stream: Invalid argument

Postby msbarc » Wed Mar 26, 2014 5:10 am

I have just installed OJS 2.3.4 with following environment
Server info:
OS: WINNT 20003 server
PHP Version: 5.2.1
Apache Version: N/A
DB Driver: mysql
DB server version: 5.5.5-m3-log

I am getting errors and warning at various notions

with law of giving one Problem at a time to foum, can some body light who to fix this problem.
error as below
ojs2 has produced an error
Message: WARNING: fopen(D:\ojs\cache\fc-core-D:\ojs\lib\pkp\registry\botAgents.txt.php) [<a href='function.fopen'>function.fopen</a>]: failed to open stream: Invalid argument
In file: D:\ojs\lib\pkp\classes\cache\FileCache.inc.php
At line: 87
Stacktrace:

JasonNugent
Site Admin
Posts: 910
Joined: Tue Jan 10, 2006 6:20 am

Re: failed to open stream: Invalid argument

Postby JasonNugent » Wed Mar 26, 2014 5:12 am

Hi msbarc,

Is there a reason why you are running such an old version? I'd first recommend trying one of our new releases and then report back. Your issues may have been solved.

Regards,
Jason

msbarc
Posts: 2
Joined: Wed Mar 12, 2014 9:19 pm

Re: failed to open stream: Invalid argument

Postby msbarc » Wed Mar 26, 2014 10:30 pm

JasonNugent wrote:Hi msbarc,

Is there a reason why you are running such an old version? I'd first recommend trying one of our new releases and then report back. Your issues may have been solved.

Regards,
Jason


Hi Jason,

Thanks for reply promptly.

I have downloaded latest OJS and its is mentioned at PKP site as Current Stable Release (December 6, 2013) Download OJS 2.4.3 (.tar.gz) (14 MB)
I have installed OJS through command prompt like C:\path-ot-OJS-in-web-dir\tools\php install.php and followed the screen. In last it shows OJS install successfully. from web browser I was not getting install button.
Yes my OS is little bit old i.e. WIN 2003 server (ent. Ed.) but PHP and MySQL version are as per the OJS 2.x sys requirements.
web server is also latest i.e. IIS 6. I am running this sys config. for many PHP/MySQL application for my Library. Kindly help me out even I have to reinstall OJS.
Thanks in advance.
Manoj Singh


Return to “General Discussion”

Who is online

Users browsing this forum: No registered users and 2 guests