OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



path is "//"

Are you an Editor, Author, or Journal Manager in need of help? Want to talk to us about workflow issues? This is your forum.

Moderators: jmacgreg, michael, vgabler, John

Forum rules
This forum is meant for general questions about the usability of OJS from an everyday user's perspective: journal managers, authors, and editors are welcome to post questions here, as are librarians and other support staff. We welcome general questions about the role of OJS and how the workflow works, as well as specific function- or user-related questions.

What to do if you have general, workflow or usability questions about OJS:

1. Read the documentation. We've written documentation to cover from OJS basics to system administration and code development, and we encourage you to read it.

2. take a look at the tutorials. We will continue to add tutorials covering OJS basics as time goes on.

3. Post a question. Questions are always welcome here, but if it's a technical question you should probably post to the OJS Technical Support subforum; if you have a development question, try the OJS Development subforum.

path is "//"

Postby rthomas » Thu May 26, 2005 9:38 am

I just installed OJS 2.0 on OS X (10.3.9) and the path has "//" in the cookie...and, of course, all the URLs. How do I correct this?

Thanks in advance.
rthomas
 
Posts: 14
Joined: Thu May 26, 2005 9:15 am

Postby kevin » Thu May 26, 2005 8:01 pm

That appears to be a bug in the system, although as far as I can tell only in the case where OJS is not under a subdirectory.

I'd suggest filing a bug through Bugzilla, but unfortunately it is inaccessible at the moment.
kevin
 
Posts: 338
Joined: Tue Oct 14, 2003 8:23 pm

Postby jasonzou » Wed Jun 08, 2005 10:02 am

Yes, If you put your OJS2 to a directory, I mean that URL looks like following:
http://www.somewhere.com/path/
The "//" bug will be fixed. Unfortunately, you will run into another problem: stuck at Login interface (if you try to log in).

Jason
jasonzou
 
Posts: 14
Joined: Thu Jun 02, 2005 7:52 am

Postby jasonzou » Wed Jun 08, 2005 1:14 pm

Weird thing just happened. I was using Firefox to test the OJS2. I used IE to access OJS2 by chance. The login problem got solved. And when I change back to Firefox, everything is fine now! Why!!!???

Jason
jasonzou
 
Posts: 14
Joined: Thu Jun 02, 2005 7:52 am

Postby kevin » Mon Jun 13, 2005 7:55 pm

The "//" issue will be resolved in OJS 2.0.1, but if you wish you can patch it manually.

Note that AFAIK this is purely a cosmetic defect and does not affect functional behaviour.
kevin
 
Posts: 338
Joined: Tue Oct 14, 2003 8:23 pm

Still having trouble after patch.

Postby rthomas » Fri Jul 08, 2005 9:09 am

I applied the patch and still have this issue. Here's what I see in the journal setting:

The journal's URL will be http://ojs.ed.uiuc.edu//index.php/<path>

What I want is this:

The journal's URL will bee http://ojs.ed.uiuc.edu/<path>

What do I need to do?
rthomas
 
Posts: 14
Joined: Thu May 26, 2005 9:15 am

Postby kevin » Fri Jul 08, 2005 9:03 pm

If properly applied, the patch (included in OJS 2.0.1 as well) should correct the "//".

The "index.php" is a required part of the URL. If you really wanted to, I imagine you could work-around it with Apache mod_rewrite rules and/or modifications to the OJS code.
kevin
 
Posts: 338
Joined: Tue Oct 14, 2003 8:23 pm


Return to OJS Editorial Support and Discussion

Who is online

Users browsing this forum: Yahoo [Bot] and 2 guests

cron