OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Basic installation problem

Are you responsible for making OCS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, michael, John

Forum rules
What to do if you have a technical problem with OCS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved. Please note that this FAQ is OJS-centric, but most issues are applicable to both platforms.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OCS Conference Support and Discussion subforum; if you have a development question, try the OCS Development subforum.

Basic installation problem

Postby Zach » Wed Jun 22, 2005 8:39 pm

Hello,

I got my copy of OCS downloaded and put everything in the right place, but I've run into a pretty big but hopefully simple problem with the install that I hope someone can help me with.

The initial symptom of the problem is that after completing the steps in install.php (with no errors), I attempt to login with the admin user/pass I just created, but get a "Login failed" message.

On further investigation, I think the problem may be that the relevant table fields (like baseurl, admin_login, etc.) aren't being updated at all by the install.php script.

This is the first time I've ever tried to interact with MySQL at all, so the problem is probably my fault. Any ideas/suggestions/solutions?

Thanks
Zach
 
Posts: 4
Joined: Wed Jun 22, 2005 8:33 pm
Location: University of Florida

Update

Postby Zach » Thu Jun 23, 2005 7:45 am

Well, changed some directory permissions, and the install script does seem to be able to write data now. I'm thinking I may have a problem with permissions in general, so is there a list somewhere of what they all should be? That would be great.
Zach
 
Posts: 4
Joined: Wed Jun 22, 2005 8:33 pm
Location: University of Florida

Re: Update

Postby Guest » Thu Jun 23, 2005 10:00 am

Zach wrote:Well, changed some directory permissions, and the install script does seem to be able to write data now. I'm thinking I may have a problem with permissions in general, so is there a list somewhere of what they all should be? That would be great.


The only directories you have to make writeable by the user running your web server (www-data in Debian Linux, for example) are:

- images
- papers

The rest of the files/directories should not be writeable by that user.

Saludos. Iñaki.
Guest
 

Postby Zach » Thu Jun 23, 2005 10:14 am

Okay, so are you saying that both 'papers' and 'images' should be:
drwxrwxrwx
and every other directory should be
drwxr-xr-x ?

Meanwhile, should all of the individual files (except for db.inc.php) be
-rwxr-xr-x
or
-rwxr--r-- ?
Zach
 
Posts: 4
Joined: Wed Jun 22, 2005 8:33 pm
Location: University of Florida

Postby Zach » Thu Jun 23, 2005 10:43 am

Gaaahh. Nevermind. I'm apparently a moron, and it's working correctly now.

Apparently I unpacked the download incorrectly, so all the file permissions were set to -rwx------, which wasn't very useful. So I painstakinglin went through each directory and changed the permissions to what I thought they should be. Obviously, something went awry in that process.

It finally occurred to me to redownload and re-install (unpacking correctly this time), and everything seems to be working.

Thanks,
Zach
Zach
 
Posts: 4
Joined: Wed Jun 22, 2005 8:33 pm
Location: University of Florida


Return to OCS Technical Support

Who is online

Users browsing this forum: Yahoo [Bot] and 1 guest