OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Current Issue not appearing

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Current Issue not appearing

Postby brianlee » Mon Jan 21, 2008 8:28 am

We have bulk loaded all the issues (back issues up to current issue) of a journal. When we click on "current issue" in the menu we get a screen that says "This journal has not published any issues." How can we make the most recent issue appear under current issues? Thanks!
brianlee
 
Posts: 32
Joined: Wed Dec 13, 2006 11:42 am

Re: Current Issue not appearing

Postby jmacgreg » Mon Jan 21, 2008 10:28 am

Hi Brianlee,

It's been a while since I've uploaded issues via the XML import path, but looking at a sample XML file there is the issue-level tag:

<issue published="false" current="false">

To have an issue be published, and then to be listed as the "current" issue without any extra measures, you'd switch those two flags to true. To upload issues as published but not current, you would set the flags as true and false, respectively.

Otherwise, you should be able to check your unpublished issues from User Home --> Editor --> Future Issues. Click on an issue title, and click the "Publish Issue" button that appears there. I think the issue with the most recent published date will automatically be listed under "Current Issue", but just to be on the safe side, publish that one last.

Cheers,
James
jmacgreg
 
Posts: 4190
Joined: Tue Feb 14, 2006 10:50 am

Re: Current Issue not appearing

Postby brianlee » Mon Jan 21, 2008 10:44 am

Thanks James. All of the issues are published and there are no future issues in the system at the moment. I don't see any way to designate an issue as "current" from within the admin interface.

In our XML we just have the tag <issue published="true"> without the "current" attribute. Does it default to "false" if it is not incuded. But on our test server, this wasn't a problem. We just loaded bulk loaded the issues and the most recent one automatically appeared as the current issue. But when we loaded onto the production server, the current issue is not appearing. Could there be some kind of server specific configuration causing this?
brianlee
 
Posts: 32
Joined: Wed Dec 13, 2006 11:42 am

Re: Current Issue not appearing

Postby jmacgreg » Mon Jan 21, 2008 10:51 am

Hi brianlee,

Just to double-check before I go digging any further -- are all your issues appearing publicly in the archives, including the one you want to appear as your current issue?

And -- which version of OJS are you using?

Thanks,
James
jmacgreg
 
Posts: 4190
Joined: Tue Feb 14, 2006 10:50 am

Re: Current Issue not appearing

Postby brianlee » Mon Jan 21, 2008 11:21 am

Yes, all the issues, including the one that should appear as most current, are appearing in the archives and are publicly accessible under the archives link. Just not appearing under the Current link....

Thanks!

Brian
brianlee
 
Posts: 32
Joined: Wed Dec 13, 2006 11:42 am

Re: Current Issue not appearing

Postby brianlee » Mon Jan 21, 2008 11:22 am

Oh...and we are using OJS 2.1.
brianlee
 
Posts: 32
Joined: Wed Dec 13, 2006 11:42 am

Re: Current Issue not appearing

Postby jmacgreg » Mon Jan 21, 2008 11:32 am

Hi Brianlee,

I think this is a small bug in the XML import function, where all issues default to current="false", even if there are no 'current' issues.

If you are using OJS 2.2, you'll have the option of assigning any published issue as the current issue from User Home --> Editor --> Back Issues. You'll see a Current Issue drop-down selection bar at the bottom of the page.

If you are using an earlier version of OJS, let me know. I believe in this case you'll have to do some quick database work.

Cheers,
James
jmacgreg
 
Posts: 4190
Joined: Tue Feb 14, 2006 10:50 am

Re: Current Issue not appearing

Postby jmacgreg » Mon Jan 21, 2008 11:34 am

Hah -- just caught the 2.1 reference.

I don't have a current version of 2.1 handy, but if memory serves, the steps I listed above for 2.2 won't apply in your case. Are you able to access your database directly?

James
jmacgreg
 
Posts: 4190
Joined: Tue Feb 14, 2006 10:50 am

Re: Current Issue not appearing

Postby brianlee » Mon Jan 21, 2008 11:37 am

I can't access the db personally, but others here can....
brianlee
 
Posts: 32
Joined: Wed Dec 13, 2006 11:42 am

Re: Current Issue not appearing

Postby jmacgreg » Mon Jan 21, 2008 11:44 am

Great. They will have to take a look at the "issues" table. What they'll have to do is make sure that the "current" column in the issues table is set to 1 only for the issue that you want to flag as the current issue. Right now, all of your issues are set to 0, or in other words, false.

Let me know how it goes,
James
jmacgreg
 
Posts: 4190
Joined: Tue Feb 14, 2006 10:50 am

Re: Current Issue not appearing

Postby brianlee » Tue Jan 22, 2008 8:10 am

That worked. Thanks a lot!
brianlee
 
Posts: 32
Joined: Wed Dec 13, 2006 11:42 am


Return to OJS Technical Support

Who is online

Users browsing this forum: Yahoo [Bot] and 1 guest