OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Strange behaviour in Submissions in Editing Page (Editor)

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Strange behaviour in Submissions in Editing Page (Editor)

Postby rania » Mon Jan 14, 2008 5:15 am

Happy new year to all! :)
The past month or so, i was busy with another project, so I've started to work again on OJS and I've noticed a strange behaviour.
In "Submissions in Editing" page of Section Editor and Editor in Chief it shows only 4 or less papers in Editing (in the table list), although there are 10 or more.
If I search for a paper by title, it will show it to me.
Also, it doesn't show the counter of items below the list (eg 1 - 4 of 4 Items) and the Sections, as it is shown in "Submissions in Review" page.
I can post a Screen Capture if necessary.
Any help would be deeply appreciated! :)
Thank you in advance!
Rania
rania
 
Posts: 35
Joined: Thu Nov 08, 2007 1:37 am

Re: Strange behaviour in Submissions in Editing Page (Editor)

Postby jmacgreg » Mon Jan 14, 2008 12:23 pm

Hi Rania,

Just a couple of questions:

Which version of OJS are you using?

In Journal Setup Step 5, at the very bottom, there should be the option to customize the maximum number of items per list. What does it say there?

Do you have the option of going backwards or forwards in a list?

Thanks,
James
jmacgreg
 
Posts: 4186
Joined: Tue Feb 14, 2006 10:50 am

Re: Strange behaviour in Submissions in Editing Page (Editor)

Postby rania » Tue Jan 15, 2008 1:02 am

Hello James!
Thank you for the quick reply!
Well, the version is 2.1.1.0, we are considering moving it to 2.2, but first we must solve this problem.
The maximum number of items in the list is 25, I think is the default.
No, I don't have the option of going backwards or forwards in a list, I can only see a paper if I know the title and search for it. There is no navigation bar or counter, counting all the items, under the list.
Also, Another thing I've noticed, based on my DB, I should have 27 papers on this journal, but the editor ( Unassigned (3), In Review (4), In Editing (10), Archives(9)) can only see 26.
Should I check for the one paper that it's missing? Maybe this is the cause of the problem?

Again, thank you for your help! :)
Rania
rania
 
Posts: 35
Joined: Thu Nov 08, 2007 1:37 am

Re: Strange behaviour in Submissions in Editing Page (Editor)

Postby jmacgreg » Tue Jan 15, 2008 12:51 pm

hi Rania,

Yes, see if you can find any record of that missing paper. Also, try sending through a new submission, from authorship to editing, and see whether it gets hung up anywhere.

Is there anything special with those missing papers? Were they submitted normally, or imported? Submitted by an author, or by a member of the editorial staff? Do the missing submissions reflect a particular time range?

Cheers,
James
jmacgreg
 
Posts: 4186
Joined: Tue Feb 14, 2006 10:50 am

Re: Strange behaviour in Submissions in Editing Page (Editor)

Postby rania » Wed Jan 16, 2008 5:46 am

Hi James!

Well, I found the missing paper and I don't think that this has anything to do with the matter. For some reason it was missing the date_submitted in MySQL table. I added a date and now it is shown in unassigned list as it should! :wink:

But I think I have found the cause of the problem and I would need your help to check why is this happening and if there is a way to prevent it.
There was an error in the last paper shown in the in Editing List, that crashes the loop and afterwards it doesn't show any other papers, old or new.
Also, if I login as author and select this paper and go to "Paper Summary>Editing", it shows me a blank page.

The error I get in the error log is:
1. For the Editor's In Editing List:
Call to a member function getDateLayoutEditorCompleted() on a non-object in /var/www/html/cache/t_compile/%%8A^8A9^8A9DBDDF%%submissionsInEditing.tpl.php on line 51, referer: http://ojs.ekt.gr/index.php/symmeikta/editor

2. For the Author's Paper Summary ("in Editing") Page:
PHP Fatal error: Call to a member function getDateAuthorUnderway() on a non-object in /var/www/html/classes/submission/proofreader/ProofreaderAction.inc.php on line 353, referer: http://ojs.ekt.gr/index.php/symmeikta/a ... mission/24

As i have noticed, there was no record of the paper with id 24 in the proof_assignments table.
This happened to 3 other papers with no particular time range. I've added the corresponding records for each of one of them in the proof_assignments table, and now the editor's list works fine.
But, why this has happened? :? Is there a way to prevent it from happening again?

All the papers in our system are submitted normally using the typical workflow by me or other persons in my team.
They are tests in order to specify some requirements for the journals and some of us have many or all the user roles, if that helps....

Again, thank you for all the help!

Cheers!
Rania
rania
 
Posts: 35
Joined: Thu Nov 08, 2007 1:37 am

Re: Strange behaviour in Submissions in Editing Page (Editor)

Postby jmacgreg » Wed Jan 16, 2008 11:58 am

Hi Rania,

I may have found a solution for you. Take a look at the following post:

viewtopic.php?f=8&t=1761

I'm guessing, as Alec has inferred in that post, that there's a database inconsistency; had you upgraded recently? You can try running that SQL query against the proper article ID, and get back to me.

Cheers,
James
jmacgreg
 
Posts: 4186
Joined: Tue Feb 14, 2006 10:50 am

Re: Strange behaviour in Submissions in Editing Page (Editor)

Postby rania » Thu Jan 17, 2008 6:48 am

Hello James!

Well, yes, more or less, that's what I did as I mentioned in the previous message and now the list in Editor's page is showing fine.
But my problem is why that had happened? (Maybe there is no answer to that, but I''m afraid if it happens again when the system is up and running) There were 3 articles having the same problem, submitted and processed at different date.
No, there was no upgrade or article import whatsover.
And there is no erro log because there has been some time. :?

Again many many thanks! :)

Rania
rania
 
Posts: 35
Joined: Thu Nov 08, 2007 1:37 am


Return to OJS Technical Support

Who is online

Users browsing this forum: No registered users and 3 guests