OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



strange import error

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

strange import error

Postby dru » Sat Jan 12, 2008 2:41 pm

I"ve successfully imported 74 html articles. For some reason, 6 of those articles don't automatically display. Instead, they give this error:

The file you selected should begin downloading automatically. If it does not, click the link below. Note that this file may require a special viewer or plugin to view.

If the file does not download automatically, click here.

and depending upon the browser, they either require a manual download of the HTML file, or if the browser opens the article, there is no CSS formatting in the article area, though the right frame still shows.

Looking at the difference in source, I noticed that the successful HTML files include "ViewArticle" in the link URL, whereas the strange articles instead are "ViewDownloadInterstitial".

Any idea what happened to make these interstitial and how do I change them to "ViewArticle"? I don't have direct access to the system's database or logs. I've tried several times uploading new galleys for these articles, but with no success.

Any suggestions appreciated.

Dru
dru
 
Posts: 5
Joined: Sat Jan 12, 2008 2:34 pm

Re: strange import error

Postby jmacgreg » Sat Jan 12, 2008 2:51 pm

Hi Dru,

Can you run down how you imported the articles -- whether individually, or as a whole issue, etc.?

Also, you may want to check the headers of the oddly acting HTML source files against one that's working. Sometimes, inconsistencies in the header can make for a problem like this (basically, OJS may be having a hard time recognizing the file as HTML, and treats it differently).

Cheers,
James
jmacgreg
 
Posts: 4190
Joined: Tue Feb 14, 2006 10:50 am

Re: strange import error

Postby dru » Sat Jan 12, 2008 3:25 pm

I imported as a whole issue (six separate issue imports, actually).

It's funny that when I "View Proof" in the HTML galley in Submissions editing, the html displays fine. I will check for HTML oddities, though all the HTML was sucked from an existing website...

Dru
dru
 
Posts: 5
Joined: Sat Jan 12, 2008 2:34 pm

Re: strange import error

Postby dru » Sat Jan 12, 2008 5:35 pm

The fix for the archives:

Use "tidy -clean" on the offending HTML document. Re-uploading into mysql doesn't seem to take; I had to delete the original galley in the Submissions Editor, then upload the clean HTML as a new galley.

Dru
dru
 
Posts: 5
Joined: Sat Jan 12, 2008 2:34 pm


Return to OJS Technical Support

Who is online

Users browsing this forum: Baidu [Spider], Google [Bot], Yahoo [Bot] and 7 guests