OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



OJS2 Reinstall problem

Are you an Editor, Author, or Journal Manager in need of help? Want to talk to us about workflow issues? This is your forum.

Moderators: jmacgreg, michael, vgabler, John

Forum rules
This forum is meant for general questions about the usability of OJS from an everyday user's perspective: journal managers, authors, and editors are welcome to post questions here, as are librarians and other support staff. We welcome general questions about the role of OJS and how the workflow works, as well as specific function- or user-related questions.

What to do if you have general, workflow or usability questions about OJS:

1. Read the documentation. We've written documentation to cover from OJS basics to system administration and code development, and we encourage you to read it.

2. take a look at the tutorials. We will continue to add tutorials covering OJS basics as time goes on.

3. Post a question. Questions are always welcome here, but if it's a technical question you should probably post to the OJS Technical Support subforum; if you have a development question, try the OJS Development subforum.

OJS2 Reinstall problem

Postby Guest » Thu May 26, 2005 7:02 pm

Hi,
While attempting to upgrade from 1.4 to 2, I sort of got everything working. Unfortunately, I was unable to login. Thinking I might have typed the password in wrong when setting it, I attempted to reinstall by dropping the ojs2 database from mysql and deleting the ojs2 directory from htdocs. I then untarred ojs into that directory, changed the permissions as the README specifies, and re-created the ojs2 database. Now, when I go to the directory via a web browser to run the install script, it outputs:

Fatal error: Cannot redeclare class virtualarrayiterator in /var/www/localhost/htdocs/ojs-2.0/includes/functions.inc.php on line 21

Is there some more installation information from the previous install hiding somewhere that I didn't purge yet?
Thanks,
Ari
Guest
 

Re: OJS2 Reinstall problem

Postby ramon » Sat May 28, 2005 5:26 pm

Ari,
I think 2.0 has 2 sets of password encryptions, so there may be your problem.

Since there is no migration system yet, it may be wise to just test 2.0 for now, copying and pasting content, until it is released.
ramon
 
Posts: 931
Joined: Wed Oct 15, 2003 6:15 am
Location: Brasí­lia/DF - Brasil

Re: OJS2 Reinstall problem

Postby Guest » Wed Jun 01, 2005 8:27 am

ramon wrote:Ari,
I think 2.0 has 2 sets of password encryptions, so there may be your problem.

Since there is no migration system yet, it may be wise to just test 2.0 for now, copying and pasting content, until it is released.


Thank you Ramon. I was hoping to migrate soon, since the journal will be launching in another month, but I that's life.
Thanks again,
Ari
Guest
 

Re: OJS2 Reinstall problem

Postby Guest » Wed Jun 15, 2005 4:24 pm

Just in case anyone has a similar problem, I have sort of solved it now. After a few weeks of trying different things, I simply installed it to another virtual host, and, for some reason, it worked fine.
Ari
Guest
 


Return to OJS Editorial Support and Discussion

Who is online

Users browsing this forum: Google [Bot], Yahoo [Bot] and 2 guests