OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Blank page - thought all conditions ok [RESOLVED]

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Blank page - thought all conditions ok [RESOLVED]

Postby mlapl1 » Thu Dec 27, 2007 6:18 pm

Hello

I am new to this board but have installed versions of OJS before.

I tried to install version 2.2 - the latest one.

When I install and navigate to the home directory to continue installation, I got a blank page.
I thought all conditions were ok. The README file says:
Recommended server requirements:

* PHP >= 4.2.x (including PHP 5.x); Microsoft IIS requires PHP 5.x
* MySQL >= 3.23.23 (including MySQL 4.x) or PostgreSQL >= 7.1 (including
PostgreSQL 8.x)
* Apache >= 1.3.2x or >= 2.0.4x or Microsoft IIS 6
* Operating system: Any OS that supports the above software, including
Linux, BSD, Solaris, Mac OS X, Windows

My server was running (in accordance with the above):
PHP 5.0.4 - 10.5.1 swsoft
Apache: 2.59 fc4
mysql 4.1.20-1.fc4.1

I then installed the same package using the same directory structures etc on a second system running - and it worked fine:
PHP 4.4.4
Apache 2.59
mysql 4.1.14.fc4.1

It seems to me that the MAIN diffs (admittedly there are two): is the PHP version. I know that 5.0 has been disliked by many systems but I have no choice in this matter for many reasons and the docs say it is ok. I would like to/need to run software on the first configuration. I have root access to the servers and some experience in modifying code etc.

Any advice would be gratefully received. This is a terrific product.

Andrew Lian
mlapl1
 
Posts: 22
Joined: Thu Dec 27, 2007 6:01 pm

Re: Blank page - thought all conditions ok

Postby mlapl1 » Thu Dec 27, 2007 6:42 pm

Further to my previous message, I have inspected the logfiles and here is what it says:

[client 125.26.79.223] PHP Warning: main() [<a href='function.main'>function.main</a>]: open_basedir restriction in effect. File(/CmsPlugin.inc.php) is not within the allowed path(s): (/var/www/vhosts/criticalpedagogy.com/httpdocs:/tmp) in /var/www/vhosts/criticalpedagogy.com/httpdocs/ajlt/journal/plugins/generic/cms/index.php on line 16

[client 125.26.79.223] PHP Warning: main(CmsPlugin.inc.php) [<a href='function.main'>function.main</a>]: failed to open stream: Operation not permitted in /var/www/vhosts/criticalpedagogy.com/httpdocs/ajlt/journal/plugins/generic/cms/index.php on line 16
[client 125.26.79.223] PHP Fatal error: main() [<a href='function.require'>function.require</a>]: Failed opening required 'CmsPlugin.inc.php' (include_path='.:/var/www/vhosts/criticalpedagogy.com/httpdocs/ajlt/journal/includes:/var/www/vhosts/criticalpedagogy.com/httpdocs/ajlt/journal/classes:/var/www/vhosts/criticalpedagogy.com/httpdocs/ajlt/journal/pages:/var/www/vhosts/criticalpedagogy.com/httpdocs/ajlt/journal/lib:/var/www/vhosts/criticalpedagogy.com/httpdocs/ajlt/journal/lib/smarty:.:.:') in /var/www/vhosts/criticalpedagogy.com/httpdocs/ajlt/journal/plugins/generic/cms/index.php on line 16

Clearly there is a path problem - BUT - I did not set up any paths or anything else.

Your assistance would be very welcome.
Andrew
mlapl1
 
Posts: 22
Joined: Thu Dec 27, 2007 6:01 pm

Re: Blank page - thought all conditions ok

Postby mlapl1 » Fri Dec 28, 2007 2:34 pm

Hello

Just as a follow up, my setup had automatically created a restriction,apparently for security, which I have now disabled and therefore everything works well. I am not an expert in these issues but maybe OJS needs to take account of these restrictions or perhaps indicate how to make appropriate adjustments (or maybe it already has and I have not seen it).

Either way, it is a wonderful product.

best wishes for a great new year for all
Andrew
mlapl1
 
Posts: 22
Joined: Thu Dec 27, 2007 6:01 pm

Re: Blank page - thought all conditions ok

Postby smiri » Sat Dec 29, 2007 12:00 am

Hi Andrew,

I would have guessed the problem is to do with permissions from your error log. I'm glad it's fixed for you now. Let us know if you encountered any more problems.

Best wishes for a great new year for you as well,
smiri
 
Posts: 183
Joined: Thu Sep 06, 2007 7:01 pm


Return to OJS Technical Support

Who is online

Users browsing this forum: Bing [Bot], Yahoo [Bot] and 5 guests