OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



HTML link won't show HTML but Article Download page

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

HTML link won't show HTML but Article Download page

Postby khellekson » Sun Dec 16, 2007 7:47 pm

http://journal.transformativeworks.org/ ... sue/view/1

The non-peer-reviewed sections, which do not have abstracts, will not publish to a real HTML page, the way the full-length (with abstract!) article does. Instead, I get the opportunity to download the file.

How can I force it to publish to a proper HTML page?

--Karen
khellekson
 
Posts: 14
Joined: Sun Nov 18, 2007 8:07 pm

Re: HTML link won't show HTML but Article Download page

Postby ramon » Mon Dec 17, 2007 6:09 am

Dear Karen,

HTML articles are usually displayed as PDF's are, in a specific frame, independent of the section and their configuration.

It's VERY odd that HTML behavior is inconsistent within one installation.

We had similar issues in a specific server when the HTML was NOT in UTF-8 encoding.
A server configuration prevented the wrongly-formatted HTML to download instead of display on the page.

Check if your HTML files are correctly encoded.

Hope this helps!

Good luck!

regards,
ramon
 
Posts: 940
Joined: Wed Oct 15, 2003 6:15 am
Location: Brasí­lia/DF - Brasil


Return to OJS Technical Support

Who is online

Users browsing this forum: No registered users and 5 guests