OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



OJS installation scripts

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

OJS installation scripts

Postby kata » Wed Dec 12, 2007 6:40 am

Hello,
I have copied the ojs files to my server, but if I try to run the index.php file in the browser, it simply loads without stopping. If I run install.php in the tools directory, it says, "Notice: Undefined index: argc in /var/www/html/web338/html/ojs/tools/includes/cliTool.inc.php on line 27

Notice: Undefined index: argv in /var/www/html/web338/html/ojs/tools/includes/cliTool.inc.php on line 28
This script can only be executed from the command-line".
What shall I do to install?
kata
 
Posts: 4
Joined: Wed Dec 12, 2007 6:32 am

Re: OJS installation scripts

Postby asmecher » Wed Dec 12, 2007 9:58 am

Hi kata,

Have you followed the instructions in docs/README? You may need to turn on the "disable_path_info" option in config.inc.php.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 9083
Joined: Wed Aug 10, 2005 12:56 pm

Re: OJS installation scripts

Postby kata » Wed Dec 12, 2007 12:53 pm

I have simply copied the ojs directory to the server and made the files writable as indicated in the readme document, and I turned the option you mentioned on, but still I encounter these problem that index.php doesn´t load and install.php produces the error message.
kata
 
Posts: 4
Joined: Wed Dec 12, 2007 6:32 am

Re: OJS installation scripts

Postby asmecher » Wed Dec 12, 2007 1:04 pm

Hi kata,

When you say that the index.php script "loads without stopping", how long have you waited? Have you checked your server log? Does your web browser report a problem with redirects or anything similar?

It may also be worth checking your server log to see if anything shows up there.

The install.php script is only intended for use from the command-line, so that message is not an error.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 9083
Joined: Wed Aug 10, 2005 12:56 pm

Re: OJS installation scripts

Postby kata » Wed Dec 12, 2007 2:31 pm

I have waited 20 minutes or so with different browsers, and it looks like it´s in progress but it does not load.
The log doesn´t say much, only many lines like +0100] "GET /ojs/index.php/index/install HTTP/1.1" 302 - "-" "Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; Alexa Toolbar)"
kata
 
Posts: 4
Joined: Wed Dec 12, 2007 6:32 am

Re: OJS installation scripts

Postby asmecher » Wed Dec 12, 2007 3:05 pm

Hi Kata,

Did you try turning on the disable_path_info option in config.inc.php as I suggested earlier?

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 9083
Joined: Wed Aug 10, 2005 12:56 pm

Re: OJS installation scripts

Postby kata » Thu Dec 13, 2007 4:43 am

Yes, I did, but it did not solve the problem.
kata
 
Posts: 4
Joined: Wed Dec 12, 2007 6:32 am

Re: OJS installation scripts

Postby asmecher » Thu Dec 13, 2007 9:36 am

Hi kata,

I'd like to investigate, if possible; if you're comfortable doing so, could you PM me with information on accessing your server?

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 9083
Joined: Wed Aug 10, 2005 12:56 pm


Return to OJS Technical Support

Who is online

Users browsing this forum: Yahoo [Bot] and 4 guests