OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



"unknown error" on harvesting

Open Harvester Systems support questions and answers, bug reports, and development issues.

Moderators: jmacgreg, michael, John

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.

"unknown error" on harvesting

Postby fredriley » Thu Oct 25, 2007 9:41 am

This isn't crucial, but could someone with a working Harvester installation please try to get records from the following base URL:

http://repository.jorum.ac.uk/intralibr ... ibrary-OAI

This is the main UK Higher Education learning object repository (http://www.jorum.ac.uk), and the base URL is the one they've given me. It works in the repository explorer at http://re.cs.uct.ac.za/ which tests repositories for OAI compliance, but Harvester twiddles its thumbs for 30 secs or so then just gives "unknown error". even when I specify start and end dates, so I'd be interested to know if this happens with others before I get onto the repository managers to tell them there's a problem. TIA.

Fred
fredriley
 
Posts: 27
Joined: Fri Sep 14, 2007 10:47 am

Re: "unknown error" on harvesting

Postby asmecher » Fri Oct 26, 2007 1:33 pm

Hi Fred,

That's definitely an OAI URL, but it doesn't appear to be working properly -- point your browser to http://repository.jorum.ac.uk/intralibrary/IntraLibrary-OAI?verb=ListRecords&metadataPrefix=oai_dc, which is a typical OAI request, and see if it works from your end. From here, the server just appears to stall.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm


Return to Open Harvester Systems Support and Development

Who is online

Users browsing this forum: No registered users and 0 guests