OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



"sudden" issues with installation

Are you responsible for making OCS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, michael, John

Forum rules
What to do if you have a technical problem with OCS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved. Please note that this FAQ is OJS-centric, but most issues are applicable to both platforms.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OCS Conference Support and Discussion subforum; if you have a development question, try the OCS Development subforum.

"sudden" issues with installation

Postby charlener » Wed Sep 19, 2007 8:06 pm

My conference director just sent me an email concerning OCS and it not working suddenly. She said that she got the following errors with nothing else on the page:

http://electroniclibrarian.org/ocs/inde ... gin/signIn
DB Error: Got error 127 from storage engine
and
http://electroniclibrarian.org/ocs
DB Error: Duplicate entry 'NULL' for key 2
and
http://electroniclibrarian.org/ocs/index.php/erl/index/
Gave a weird error that seemed to have a SHA1 key or something in it, then began working again

Oddly enough, after that last page and refreshing it, everything seems to work again. Weird, huh? Could this possibly have to do with logins/authentication? I do have the OCS DB as the primary db source for logins for legacy site (moodle) and related groupblog (wordpress).

Charlene
charlener
 
Posts: 10
Joined: Wed May 02, 2007 9:48 am

Re: "sudden" issues with installation

Postby asmecher » Wed Sep 19, 2007 8:18 pm

Hi Charlene,

Odd indeed -- have you checked your database server's disk to make sure there's space? I've received a storage engine error 127 when a disk filled up.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8869
Joined: Wed Aug 10, 2005 12:56 pm

Re: "sudden" issues with installation

Postby charlener » Thu Sep 20, 2007 9:19 pm

I've looked at the service status on the provider (it's hosted/shared space) and it looks ok. She's checking with their guys too though. The other new oddity is today I'm seeing

DB Error: User XXXX_ocs has already more than 'max_user_connections' active connections

When I try to login to the other apps that authenticate to the database. Maybe this is a silly question, but does OCS use persistent logins? And would it be a good idea to have the other apps use different/new user logins?
charlener
 
Posts: 10
Joined: Wed May 02, 2007 9:48 am

Re: "sudden" issues with installation

Postby asmecher » Fri Sep 21, 2007 8:02 am

Hi charlener,

Yes, OCS uses persistent connections, but you can disable this in config.inc.php in the "persistent" directive. Disabling this won't cause any problems or even affect performance in a significant way, but I'd also suggest continuing to talk to your host about that storage engine problem, just to make sure everything is OK.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8869
Joined: Wed Aug 10, 2005 12:56 pm

Re: "sudden" issues with installation

Postby charlener » Mon Sep 24, 2007 12:07 am

I have been told there was some "file corruption", and that's been fixed, so the problem seems to have resolved itself. I'm still setting up separate logins for the apps now, though, and likely will turn off persistent connections just in case.

Thanks for the advice :)
charlener
 
Posts: 10
Joined: Wed May 02, 2007 9:48 am


Return to OCS Technical Support

Who is online

Users browsing this forum: No registered users and 1 guest

cron