OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



OJS search stopped working

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

OJS search stopped working

Postby shubhash » Wed Aug 29, 2007 3:03 pm

Hi Alec, The search in our OJS journal was working previously. We didn't have pdftotext enabled, but enabled it recently. Then ran the script "tools/rebuildSearchIndex.php" to rebuild the index. Now it rebuilt the index, but the searching function severely broke. i.e. It does not search the metadata fields at all. It finds results only based on the body of the articles. I.e. if I search for the name of an author, it returns zero results even though that person is an author for several articles. So I think the "rebuildSearchIndex" script perhaps deleted the existing list of keywords from the database and inserted new ones from the body of the articles. Do you know why this happened or how to fix it ? Is there a way to restore the keywords from the metadata of the articles? The OJS version is 2.1.1.0. Thanks for help.
shubhash
 
Posts: 39
Joined: Tue Feb 28, 2006 10:13 am

Re: OJS search stopped working

Postby asmecher » Wed Aug 29, 2007 3:22 pm

Hi Shubhash,

The rebuildSearchIndex.php tool does delete all previously indexed data, but it should re-index both the body of the articles and their metadata. Could you double-check that there were no error messages reported? Check the display_errors setting in your php.ini file; often there's a separate php.ini for CLI PHP, so you may have to go looking for it.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8857
Joined: Wed Aug 10, 2005 12:56 pm

Re: OJS search stopped working

Postby shubhash » Thu Aug 30, 2007 1:41 pm

Thanks Alec. I found that the rebuildSearchIndex.php script was timing out and was not completing the indexing process. In our system, for some reason the CLI PHP uses same php.ini as the web PHP. Anyway after temporarily disabling the execution time limit, it seems to do the indexing properly.
shubhash
 
Posts: 39
Joined: Tue Feb 28, 2006 10:13 am


Return to OJS Technical Support

Who is online

Users browsing this forum: Google [Bot] and 7 guests