OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Too much warning messages after set up

Are you an Editor, Author, or Journal Manager in need of help? Want to talk to us about workflow issues? This is your forum.

Moderators: jmacgreg, michael, vgabler, John

Forum rules
This forum is meant for general questions about the usability of OJS from an everyday user's perspective: journal managers, authors, and editors are welcome to post questions here, as are librarians and other support staff. We welcome general questions about the role of OJS and how the workflow works, as well as specific function- or user-related questions.

What to do if you have general, workflow or usability questions about OJS:

1. Read the documentation. We've written documentation to cover from OJS basics to system administration and code development, and we encourage you to read it.

2. take a look at the tutorials. We will continue to add tutorials covering OJS basics as time goes on.

3. Post a question. Questions are always welcome here, but if it's a technical question you should probably post to the OJS Technical Support subforum; if you have a development question, try the OJS Development subforum.

Too much warning messages after set up

Postby ainge » Thu Feb 19, 2004 7:07 am

Hello!

I just have tried installing OJS after coming from a presentation by John. After installation, I get the following error on every included page:
Warning: ini_set(): A session is active. You cannot change the session module's ini settings at this time. in /archives/wwwroot/journal/include/session.inc.php on line 39

Warning: ini_set(): A session is active. You cannot change the session module's ini settings at this time. in /archives/wwwroot/journal/include/session.inc.php on line 40


I thought it must be a browser session or something. I tried on different browsers but still I get the same error. When I tried to login by the 'Login' link, I got this below the 2 warnings:
Warning: Cannot modify header information - headers already sent by (output started at /archives/wwwroot/journal/include/session.inc.php:39) in /archives/wwwroot/journal/include/functions.inc.php on line 59


I installed in a RedHat Linux with
PHP 4.3.3
Apache 1.3.28
MySQL 2.23.49

What could be the problem? Thank you in advance.
ainge
 
Posts: 3
Joined: Thu Feb 19, 2004 6:19 am
Location: San Fernando, LU, Philippines

Postby kevin » Thu Feb 19, 2004 12:20 pm

Do you have the session.auto_start setting enabled in your php.ini? If so, you will need to disable it.
kevin
 
Posts: 338
Joined: Tue Oct 14, 2003 8:23 pm

Postby ainge » Fri Feb 20, 2004 1:45 am

Kevin,

Thank you for the immediate reply.

I have checked it and it is set to 0 with session.cookie_lifetime also set to 0 -- until browser restarts.

I tried deleting my temporary internet files and history and so on, but still i get the same error.
ainge
 
Posts: 3
Joined: Thu Feb 19, 2004 6:19 am
Location: San Fernando, LU, Philippines

Postby kevin » Fri Feb 20, 2004 1:03 pm

Could you post your php.ini (or email to ojs@pkp.ubc.ca)?
kevin
 
Posts: 338
Joined: Tue Oct 14, 2003 8:23 pm

Postby Guest » Tue Mar 02, 2004 4:30 am

[PHP]


engine = On
short_open_tag = On
asp_tags = Off
precision = 12
y2k_compliance = On
output_buffering = Off
zlib.output_compression = Off
implicit_flush = Off
unserialize_callback_func=
serialize_precision = 100
allow_call_time_pass_reference = On
safe_mode = Off
safe_mode_gid = Off
safe_mode_include_dir =
safe_mode_exec_dir =
safe_mode_allowed_env_vars = PHP_
safe_mode_protected_env_vars = LD_LIBRARY_PATH
disable_functions =
disable_classes =
expose_php = On
max_execution_time = 30
max_input_time = 60
memory_limit = 8M
error_reporting = E_ALL & ~E_NOTICE
display_errors = On
display_startup_errors = Off
log_errors = On
log_errors_max_len = 1024
ignore_repeated_errors = Off
ignore_repeated_source = Off
report_memleaks = On
track_errors = Off
error_log = /home/root/phperrors.err
variables_order = "EGPCS"
register_globals = On
register_argc_argv = On
post_max_size = 8M
gpc_order = "GPC"
magic_quotes_gpc = On
magic_quotes_runtime = Off
magic_quotes_sybase = Off
auto_prepend_file =
auto_append_file =
default_mimetype = "text/html"
doc_root =
user_dir =
extension_dir = "/usr/local/lib"
enable_dl = On
file_uploads = On
upload_tmp_dir = /tmp/phpupload
upload_max_filesize = 2M
allow_url_fopen = On
default_socket_timeout = 60
extension=libpdf_php.so

extension="mmcache.so"
mmcache.shm_size="16"
mmcache.cache_dir="/tmp/mmcache"
mmcache.enable="1"
mmcache.optimizer="1"
mmcache.check_mtime="1"
mmcache.debug="0"
mmcache.filter=""
mmcache.shm_max="0"
mmcache.shm_ttl="0"
mmcache.shm_prune_period="0"
mmcache.shm_only="0"
mmcache.compress="1"

define_syslog_variables = Off
SMTP = localhost
sendmail_from = aims@localhost
sendmail_path = /usr/sbin/sendmail
sql.safe_mode = Off
odbc.allow_persistent = On
odbc.check_persistent = On
odbc.max_persistent = -1
odbc.max_links = -1
odbc.defaultlrl = 4096
odbc.defaultbinmode = 1
mysql.allow_persistent = On
mysql.max_persistent = -1
mysql.max_links = -1
mysql.default_port =
mysql.default_socket =
mysql.default_host =
mysql.default_user =
mysql.default_password =
mysql.connect_timeout = 60
mysql.trace_mode = Off
msql.allow_persistent = On
msql.max_persistent = -1
msql.max_links = -1
pgsql.allow_persistent = On
pgsql.auto_reset_persistent = Off
pgsql.max_persistent = -1
pgsql.max_links = -1
pgsql.ignore_notice = 0
pgsql.log_notice = 0
sybase.allow_persistent = On
sybase.max_persistent = -1
sybase.max_links = -1
sybase.min_error_severity = 10
sybase.min_message_severity = 10
sybase.compatability_mode = Off
sybct.allow_persistent = On
sybct.max_persistent = -1
sybct.max_links = -1
sybct.min_server_severity = 10
sybct.min_client_severity = 10
dbx.colnames_case = "unchanged"
bcmath.scale = 0
ifx.default_host =
ifx.default_user =
ifx.default_password =
ifx.allow_persistent = On
ifx.max_persistent = -1
ifx.max_links = -1
ifx.textasvarchar = 0
ifx.byteasvarchar = 0
ifx.charasvarchar = 0
ifx.blobinfile = 0
ifx.nullformat = 0
session.save_handler = files
session.save_path = /tmp
session.use_cookies = 1
session.name = PHPSESSID
session.auto_start = 0
session.cookie_lifetime = 0
session.cookie_path = /
session.cookie_domain =
session.serialize_handler = php
session.gc_probability = 1
session.gc_divisor = 100
session.gc_maxlifetime = 1440
session.bug_compat_42 = 1
session.bug_compat_warn = 1
session.referer_check =
session.entropy_length = 0
session.entropy_file =
session.cache_limiter = nocache
session.cache_expire = 180
session.use_trans_sid = 0
url_rewriter.tags = "a=href,area=href,frame=src,input=src,form=,fieldset="
mssql.allow_persistent = On
mssql.max_persistent = -1
mssql.max_links = -1
mssql.min_error_severity = 10
mssql.min_message_severity = 10
mssql.compatability_mode = Off
mssql.secure_connection = Off
ingres.allow_persistent = On
ingres.max_persistent = -1
ingres.max_links = -1
ingres.default_database =
ingres.default_user =
ingres.default_password =
pfpro.defaulthost = "test-payflow.verisign.com"
pfpro.defaultport = 443
pfpro.defaulttimeout = 30
sockets.use_system_read = On
; End:
Guest
 

Postby kevin » Wed Mar 03, 2004 5:18 pm

Sorry, I haven't had any success in repeating this problem. Unless your server has session.auto_start enabled in some other way (Apache configuration, or a .htaccess file), I'm not sure what's going on. The PHP web site shows this bug which could be related.

If you are not able to resolve this, you can edit include/common.php and change:

Code: Select all
// start session
startSession();

to
Code: Select all
// start session
session_start();


This makes OJS use PHP's default file-based sessions instead of the custom OJS session handler. It's certainly not an ideal solution, but it shouldn't have any noticeable affect on functionality.
kevin
 
Posts: 338
Joined: Tue Oct 14, 2003 8:23 pm

Postby ainge » Sun Mar 07, 2004 4:58 am

thank you for the effort of trying to resolve it. Your alternative have made it work for me. Any sacrifice this might have caused?

I appreciate it very much.
ainge
 
Posts: 3
Joined: Thu Feb 19, 2004 6:19 am
Location: San Fernando, LU, Philippines

Postby kevin » Mon Mar 08, 2004 2:10 pm

ainge wrote:Any sacrifice this might have caused?


Not really. Using the default session handler is arguably a bit less secure, but there is no difference in functionality.
kevin
 
Posts: 338
Joined: Tue Oct 14, 2003 8:23 pm


Return to OJS Editorial Support and Discussion

Who is online

Users browsing this forum: No registered users and 6 guests