OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Problem with locales

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Problem with locales

Postby leossa » Fri Jun 29, 2007 8:45 am

Hello,

I'm having a problem here with the locales since I cleared the cache data on my OJS.
It seems like it was not finding the locale files, because I get this, for instance, when I get to the System Plugins interface:

...
##plugins.generic.webfeed.displayName##
...

It's printing the method name displayName in the page instead of actually executing it and getting the string.
After that, I managed to do a `php /tools/localeCheck()` and I found that my many locales were missing, consequence of the clear cache data I did before I guess.

So, I'm sorry for the probably simple question, but I'm new to OJS and hope anyone can give me the tips to solve this.

Thanks in advance.

Leonardo

PS.: I have already executed the tool script preCompile.php also with no success.
leossa
 
Posts: 11
Joined: Thu Jun 28, 2007 4:25 pm

Postby asmecher » Fri Jun 29, 2007 7:01 pm

Hi Leonardo,

Try deleting all .php files in your cache directory and making sure that the directory can be administered (i.e. files created and deleted) by the web server user, typically "apache" or "www-data" on a *NIX system.

Regards,
Alec Smecher
Public Knowledge Project Team
---
Don't miss the First International PKP Scholarly Publishing Conference
July 11 - 13, 2007, Vancouver, BC, Canada
http://ocs.sfu.ca/pkp2007/
asmecher
 
Posts: 7743
Joined: Wed Aug 10, 2005 12:56 pm

Postby leossa » Tue Jul 03, 2007 10:11 am

Hello asmecher,

thank you for the reply, but infortunately it doesn't solved it my problem.
Any ideas of what can be causing it?

Leonardo
leossa
 
Posts: 11
Joined: Thu Jun 28, 2007 4:25 pm

Postby asmecher » Tue Jul 03, 2007 10:34 am

Hi Leonardo,

Are you using a stock version of OJS, and is the language set to English? The plugins.generic.webfeed.displayName locale key should be defined in plugins/generic/webFeed/locale/en_US/locale.xml.

Regards,
Alec Smecher
Public Knowledge Project Team
---
Don't miss the First International PKP Scholarly Publishing Conference
July 11 - 13, 2007, Vancouver, BC, Canada
http://ocs.sfu.ca/pkp2007/
asmecher
 
Posts: 7743
Joined: Wed Aug 10, 2005 12:56 pm


Return to OJS Technical Support

Who is online

Users browsing this forum: No registered users and 4 guests