OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



reviewer comments not works

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

reviewer comments not works

Postby tarkhorani » Fri Jun 15, 2007 8:43 am

when a reviewer accept to review a manuscript when he click on a icon tu submit the review a pop up page opens then write the comments and click submit but page goes to a white page and no review recorded.
tarkhorani
 
Posts: 91
Joined: Fri May 18, 2007 6:30 am

Postby asmecher » Fri Jun 15, 2007 9:26 am

Hi tarkhorani,

Check your error log -- a blank page is usually accompanied by an error message. With Apache, it'll generally be in a file called error_log. Alternately, you can add the following near the top of index.php:
Code: Select all
ini_set('display_errors', E_ALL);
This will cause errors to be displayed to the browser, which is useful for debugging (but shouldn't be left on production machines).

Regards,
Alec Smecher
Public Knowledge Project Team
---
Don't miss the First International PKP Scholarly Publishing Conference
July 11 - 13, 2007, Vancouver, BC, Canada
http://ocs.sfu.ca/pkp2007/
asmecher
 
Posts: 7696
Joined: Wed Aug 10, 2005 12:56 pm

Postby tarkhorani » Sun Jun 17, 2007 12:04 pm

no error reported on error log ; it is related to this post:

viewtopic.php?t=1557
tarkhorani
 
Posts: 91
Joined: Fri May 18, 2007 6:30 am

Postby tarkhorani » Sun Jun 17, 2007 11:39 pm

I am using PHP 5+ and mysql 5+
tarkhorani
 
Posts: 91
Joined: Fri May 18, 2007 6:30 am

Postby asmecher » Mon Jun 18, 2007 9:55 am

Hi tarkhorani,

I suspect this is not related to the Zend Optimizer bug, but just in case, have you tried following the solutions suggested on that page (i.e. either applying the patch or disabling Zend Optimizer)? Did you try adding the ini_set statement above?

Also double-check to make sure that your cache directory, particularly the t_compile subdirectory and its contents, can be written to by the web server. Using the -R option to chmod and chown is the best way to do this (on a *NIX platform).

Regards,
Alec Smecher
Public Knowledge Project Team
---
Don't miss the First International PKP Scholarly Publishing Conference
July 11 - 13, 2007, Vancouver, BC, Canada
http://ocs.sfu.ca/pkp2007/
asmecher
 
Posts: 7696
Joined: Wed Aug 10, 2005 12:56 pm

Postby tarkhorani » Mon Jun 18, 2007 1:25 pm

yes, I installed the patch
I installed another copy as test on another domain and it does not works,
the test installed on haraj.org domain. if you want I can give you user/pass to take a check.

Sincerely
tarkhorani
 
Posts: 91
Joined: Fri May 18, 2007 6:30 am

Postby asmecher » Mon Jun 18, 2007 2:22 pm

Hi tarkhorani,

Please PM me access information and I'll see what I can do.

Regards,
Alec Smecher
Public Knowledge Project Team
---
Don't miss the First International PKP Scholarly Publishing Conference
July 11 - 13, 2007, Vancouver, BC, Canada
http://ocs.sfu.ca/pkp2007/
asmecher
 
Posts: 7696
Joined: Wed Aug 10, 2005 12:56 pm

Postby asmecher » Mon Jun 18, 2007 2:50 pm

Hi tarkhorani,

It looks like the patch to classes/db/DAO.inc.php wasn't completely applied -- there is a file in classes/db called DAO.inc.php.rej that contains the change that still needs to be made.

Regards,
Alec Smecher
Public Knowledge Project Team
---
Don't miss the First International PKP Scholarly Publishing Conference
July 11 - 13, 2007, Vancouver, BC, Canada
http://ocs.sfu.ca/pkp2007/
asmecher
 
Posts: 7696
Joined: Wed Aug 10, 2005 12:56 pm

Postby tarkhorani » Mon Jun 18, 2007 2:53 pm

when I applied the patch , it showed 5 of 6 done.
it is because of it and how I can force the patch to do the remain job?

thank You!
tarkhorani
 
Posts: 91
Joined: Fri May 18, 2007 6:30 am

Postby asmecher » Mon Jun 18, 2007 3:00 pm

Hi tarkhorani,

I'm not sure what caused the patch not to apply fully, but you can finish the job by finding the following line in the "update" function in classes/db/DAO.inc.php:
Code: Select all
if ($callHooks === true && checkPhpVersion('4.3.0')) {
...and changing it to...
Code: Select all
if (false && $callHooks === true && checkPhpVersion('4.3.0')) {
Regards,
Alec Smecher
Public Knowledge Project Team
---
Don't miss the First International PKP Scholarly Publishing Conference
July 11 - 13, 2007, Vancouver, BC, Canada
http://ocs.sfu.ca/pkp2007/
asmecher
 
Posts: 7696
Joined: Wed Aug 10, 2005 12:56 pm

Postby tarkhorani » Tue Jun 19, 2007 6:44 am

ok, solved thank you!
tarkhorani
 
Posts: 91
Joined: Fri May 18, 2007 6:30 am


Return to OJS Technical Support

Who is online

Users browsing this forum: Google [Bot] and 4 guests