OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Can't login on apache/windows

Are you responsible for making OCS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, michael, John

Forum rules
What to do if you have a technical problem with OCS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved. Please note that this FAQ is OJS-centric, but most issues are applicable to both platforms.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OCS Conference Support and Discussion subforum; if you have a development question, try the OCS Development subforum.

Can't login on apache/windows

Postby eggsurplus » Mon May 21, 2007 10:06 am

When I try to log in with the correct password I get forwarded to index.php?conference=index&schedConf=index&page=login&op=signIn which displays "Page cannot be displayed".

I'm using Apache 2.2/PHP 5.2 on Windows 2003 SP2.
I changed disable_path_info = Off to On to see if that was the issue. This happens when logging out as well:
index.php?conference=index&schedConf=index&page=login&op=signOut
The page cannot be displayed

Thanks,
eggsurplus
 
Posts: 4
Joined: Mon May 21, 2007 10:02 am

Postby asmecher » Tue May 22, 2007 9:28 am

Hi eggsurplus,

With disable_path_info set to On, are you able to view that URL if you type it in manually? FYI, I'd suggest turning disable_path_info to "Off" if at all possible. When disable_path_info is Off, URLs won't use GET parameters, so the above URLs you listed won't work properly (and OJS won't generate them).

Regards,
Alec Smecher
Open Journal Systems Team
---
Don't miss the First International PKP Scholarly Publishing Conference
July 11 - 13, 2007, Vancouver, BC, Canada
http://ocs.sfu.ca/pkp2007/
asmecher
 
Posts: 8860
Joined: Wed Aug 10, 2005 12:56 pm

Postby eggsurplus » Tue May 22, 2007 10:45 am

Thanks for looking at this Alec.

I should have been more specific. I first tried this with disable_path_info = Off and kept getting "The page cannot be displayed" only on a correct password attempt. Incorrect passwords would forward back to the login page for a reattempt. I then tried to set disable_path_info = On to see the issue was due to the url string and how php 5.2 and apache 2.2 handles it.

So we're still stuck not being able to log in and move around the system without getting errors on most pages.
eggsurplus
 
Posts: 4
Joined: Mon May 21, 2007 10:02 am

Postby asmecher » Tue May 22, 2007 10:48 am

Hi eggsurplus,

Very strange. Could you check your error log to see if anything more specific appears in there? If you're using Apache on Windows, it should be in Apache's log directory, probably in the error_log.

I'd also suggest checking to make sure that PHP's memory_limit is set to 16M; the default of 8M is often not enough. You'll have to restart Apache if you change this.

Regards,
Alec Smecher
Open Journal Systems Team
Public Knowledge Project Team
---
Don't miss the First International PKP Scholarly Publishing Conference
July 11 - 13, 2007, Vancouver, BC, Canada
http://ocs.sfu.ca/pkp2007/
asmecher
 
Posts: 8860
Joined: Wed Aug 10, 2005 12:56 pm

Postby eggsurplus » Tue May 22, 2007 12:13 pm

memory is set to 32M

Here's what is added to the log when I attempt a login:

[Tue May 22 14:03:45 2007] [notice] Parent: child process exited with status 3221225477 -- Restarting.
[Tue May 22 14:03:47 2007] [notice] Apache/2.2.4 (Win32) DAV/2 mod_ssl/2.2.4 OpenSSL/0.9.8d mod_autoindex_color PHP/5.2.1 configured -- resuming normal operations
[Tue May 22 14:03:47 2007] [notice] Server built: Jan 30 2007 12:11:56
[Tue May 22 14:03:47 2007] [notice] Parent: Created child process 1836
[Tue May 22 14:03:48 2007] [notice] Child 1836: Child process is running
[Tue May 22 14:03:48 2007] [notice] Child 1836: Acquired the start mutex.
[Tue May 22 14:03:48 2007] [notice] Child 1836: Starting 250 worker threads.
[Tue May 22 14:03:48 2007] [notice] Child 1836: Starting thread to listen on port 443.
[Tue May 22 14:03:48 2007] [notice] Child 1836: Starting thread to listen on port 80.
[Tue May 22 14:03:54 2007] [notice] Parent: child process exited with status 3221225477 -- Restarting.
[Tue May 22 14:03:55 2007] [notice] Apache/2.2.4 (Win32) DAV/2 mod_ssl/2.2.4 OpenSSL/0.9.8d mod_autoindex_color PHP/5.2.1 configured -- resuming normal operations
[Tue May 22 14:03:55 2007] [notice] Server built: Jan 30 2007 12:11:56
[Tue May 22 14:03:55 2007] [notice] Parent: Created child process 6068
[Tue May 22 14:03:57 2007] [notice] Child 6068: Child process is running
[Tue May 22 14:03:57 2007] [notice] Child 6068: Acquired the start mutex.
[Tue May 22 14:03:57 2007] [notice] Child 6068: Starting 250 worker threads.
[Tue May 22 14:03:57 2007] [notice] Child 6068: Starting thread to listen on port 443.
[Tue May 22 14:03:57 2007] [notice] Child 6068: Starting thread to listen on port 80.
eggsurplus
 
Posts: 4
Joined: Mon May 21, 2007 10:02 am

Postby asmecher » Tue May 22, 2007 12:21 pm

Hi eggsurplus,

This looks to me like a bug in the Zend Optimizer, which is often shipped as part of a WAMP stack. See http://pkp.sfu.ca/support/forum/viewtopic.php?t=1666&start=15 for a discussion of the problem and a link to a patch that should work around it.

Regards,
Alec Smecher
Public Knowledge Project Team
---
Don't miss the First International PKP Scholarly Publishing Conference
July 11 - 13, 2007, Vancouver, BC, Canada
http://ocs.sfu.ca/pkp2007/
asmecher
 
Posts: 8860
Joined: Wed Aug 10, 2005 12:56 pm

Postby eggsurplus » Tue May 22, 2007 12:51 pm

Thanks!

I updated the ZendOptimizer to the latest version and it solved the issue.
eggsurplus
 
Posts: 4
Joined: Mon May 21, 2007 10:02 am


Return to OCS Technical Support

Who is online

Users browsing this forum: Bing [Bot], Yahoo [Bot] and 1 guest