OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



A misconfiguration on the server caused a hiccup???

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

A misconfiguration on the server caused a hiccup???

Postby Carlo » Wed Apr 25, 2007 8:42 am

I started a journal using OJS and a few weeks after installed, suddenly, I can't access the page. The browser show this error message:

-------------------------------------
500 Server Error
A misconfiguration on the server caused a hiccup. Check the server logs, fix the problem, then try again.
-------------------------------------

The host support said that the server is ok, and doesn't make any change that could affect the site.

Could be some kind of bug or some automatic change made by OJS system?

Or something related to config.inc or index file?

Someone could help me?

If it's necessary I can post the 2 files above.

I'm trying avoid install the whole program again (besides this I'm not sure if the problem could happen again).

Thanks in advance
Carlo
 
Posts: 6
Joined: Wed Apr 25, 2007 7:57 am
Location: São Paulo - BRAZIL

Postby asmecher » Wed Apr 25, 2007 10:13 am

Hi Carlo,

Very strange -- and difficult to debug, as the message doesn't provide any details. First, try turning on the "disable_path_info" option in config.inc.php. If this starts OJS working again, then the problem was caused by a subtle configuration change at the web server.

If that doesn't work, let me know and I'll see what else I can suggest.

Regards,
Alec Smecher
Open Journal Systems Team
---
Don't miss the First International PKP Scholarly Publishing Conference
July 11 - 13, 2007, Vancouver, BC, Canada
http://ocs.sfu.ca/pkp2007/
asmecher
 
Posts: 8597
Joined: Wed Aug 10, 2005 12:56 pm

I did your suggestion...

Postby Carlo » Thu Apr 26, 2007 6:07 am

Hi Alec,
thanks for your prompt answer.

I did the change that you suggest, waited a few hours for some delay, and the journal are still inacessible.

I'm very afraid because this will be the first edition of the journal.

If you think could better to you analise teh problem, I can send you the config.inc and index files (maybe through other email).

Or tell me if you have some more suggestion.
Regards
Carlo
 
Posts: 6
Joined: Wed Apr 25, 2007 7:57 am
Location: São Paulo - BRAZIL

Postby asmecher » Thu Apr 26, 2007 10:19 am

Hi Carlo,

Have you tried creating a test .php to make sure the server is configured to run PHP properly? Create a file called test.php in your web root with the following contents:
Code: Select all
<?php phpinfo(); ?>
Point your browser to it and make sure you get a bunch of PHP configuration info.

Another problem people have had with shared hosts is that the host has installed Zend Optimizer; releases prior to 3.2.6 have a bug that prevents OJS from running. You can find out whether Zend Optimizer is running from the debug output generated above.

Regards,
Alec Smecher
Open Journal Systems Team
---
Don't miss the First International PKP Scholarly Publishing Conference
July 11 - 13, 2007, Vancouver, BC, Canada
http://ocs.sfu.ca/pkp2007/
asmecher
 
Posts: 8597
Joined: Wed Aug 10, 2005 12:56 pm

Postby Carlo » Thu Apr 26, 2007 11:22 am

Hi Alec
Below follow the info (I'd put more details in case be helpful).

===============================
PHP Version 4.4.6

System Linux box170.bluehost.com 2.6.19-1_3.BHsmp #1 SMP Mon Jan 15 07:50:58 MST 2007 x86_64
Build Date Apr 3 2007 17:20:13
Configure Command './configure' '--enable-pic' '--with-libdir=lib64' '--prefix=/usr' '--with-xml' '--enable-bcmath' '--enable-calendar' '--with-curl' '--with-dom' '--with-dom-xslt' '--with-dom-exslt' '--enable-exif' '--enable-fastcgi' '--with-fastcgi=/usr' '--enable-ftp' '--with-gd' '--with-jpeg-dir=/usr/local' '--with-png-dir=/usr' '--with-xpm-dir=/usr/X11R6' '--with-gettext' '--with-iconv' '--with-imap=/usr/local/imap-2004g' '--enable-mbstring' '--enable-mbstr-enc-trans' '--enable-mbregex' '--with-mcrypt' '--with-mhash' '--enable-magic-quotes' '--with-mysqli' '--with-mysql=/usr' '--with-openssl' '--enable-discard-path' '--with-pdflib' '--with-pear' '--with-pgsql=/usr' '--with-pspell' '--enable-xslt' '--with-xslt-sablot' '--enable-sockets' '--enable-track-vars' '--with-ttf' '--with-freetype-dir=/usr' '--enable-gd-native-ttf' '--with-zlib'
Server API CGI/FastCGI
Virtual Directory Support disabled
Configuration File (php.ini) Path /home/abrapesp/public_html/php.ini
PHP API 20020918
PHP Extension 20020429
Zend Extension 20050606
Debug Build no
Zend Memory Manager enabled
Thread Safety disabled
Registered PHP Streams php, http, ftp, https, ftps, compress.zlib
----------------
This program makes use of the Zend Scripting Language Engine:
Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies with Zend Extension Manager v1.2.0, Copyright (c) 2003-2006, by Zend Technologies with Zend Optimizer v3.2.6, Copyright (c) 1998-2007, by Zend Technologies
----------------
Configuration
PHP Core
Directive Local Value Master Value
allow_call_time_pass_reference On On
allow_url_fopen On On
always_populate_raw_post_data Off Off
arg_separator.input & &
arg_separator.output & &
asp_tags Off Off
auto_append_file no value no value
auto_prepend_file no value no value
browscap no value no value
default_charset no value no value
default_mimetype text/html text/html
define_syslog_variables Off Off
disable_classes no value no value
disable_functions no value no value
display_errors On On
display_startup_errors Off Off
doc_root no value no value
docref_ext no value no value
docref_root no value no value
enable_dl On On
error_append_string no value no value
error_log error_log error_log
error_prepend_string no value no value
error_reporting 2039 2039
expose_php On On
extension_dir ./ ./
file_uploads On On
gpc_order GPC GPC
highlight.bg #FFFFFF #FFFFFF
highlight.comment #FF8000 #FF8000
highlight.default #0000BB #0000BB
highlight.html #000000 #000000
highlight.keyword #007700 #007700
highlight.string #DD0000 #DD0000
html_errors On On
ignore_repeated_errors Off Off
ignore_repeated_source Off Off
ignore_user_abort Off Off
implicit_flush Off Off
include_path .:/usr/lib/php:/usr/local/lib/php .:/usr/lib/php:/usr/local/lib/php
log_errors On On
log_errors_max_len 1024 1024
magic_quotes_gpc On On
magic_quotes_runtime Off Off
magic_quotes_sybase Off Off
max_execution_time 30 30
max_input_time -1 -1
open_basedir no value no value
output_buffering no value no value
output_handler no value no value
post_max_size 55M 55M
precision 14 14
register_argc_argv On On
register_globals On On
report_memleaks On On
safe_mode Off Off
safe_mode_exec_dir no value no value
safe_mode_gid Off Off
safe_mode_include_dir no value no value
sendmail_from no value no value
sendmail_path /usr/sbin/sendmail -t -i /usr/sbin/sendmail -t -i
serialize_precision 100 100
short_open_tag On On
SMTP localhost localhost
smtp_port 25 25
sql.safe_mode Off Off
track_errors Off Off
unserialize_callback_func no value no value
upload_max_filesize 2M 2M
upload_tmp_dir no value no value
user_dir no value no value
variables_order EGPCS EGPCS
xmlrpc_error_number 0 0
xmlrpc_errors Off Off
y2k_compliance Off Off
-------------------------------------
Zend Optimizer
Optimization Pass 1 enabled
Optimization Pass 2 enabled
Optimization Pass 3 enabled
Optimization Pass 4 enabled
Optimization Pass 9 disabled
Zend Loader enabled
License Path no value
Obfuscation level 3
--------------------------------------

zlib
ZLib Support enabled
Compiled Version 1.2.1.2
Linked Version 1.2.1.2

Directive Local Value Master Value
zlib.output_compression Off Off
zlib.output_compression_level -1 -1
zlib.output_handler no value no value
---------------------------------------------------------------------


It was not clear for me the Zend Optmizer in question.
But, as I said, the site was ok for a month and a half, before got problem.

Regards
Carlo
Carlo
 
Posts: 6
Joined: Wed Apr 25, 2007 7:57 am
Location: São Paulo - BRAZIL

Postby asmecher » Thu Apr 26, 2007 11:43 am

Hi Carlo,

Your host is running Zend Optimizer, some configurations of which are known to be buggy. See http://pkp.sfu.ca/support/forum/viewtopic.php?t=1666 for a discussion of this and a link to a work-around patch for OJS that should correct the problem if my guess is correct.

Regards,
Alec Smecher
Open Journal Systems Team
---
Don't miss the First International PKP Scholarly Publishing Conference
July 11 - 13, 2007, Vancouver, BC, Canada
http://ocs.sfu.ca/pkp2007/
asmecher
 
Posts: 8597
Joined: Wed Aug 10, 2005 12:56 pm

Postby Carlo » Thu Apr 26, 2007 12:23 pm

OK, Alec, i'll try.

I found this information at bluehost (the host that I use) forum.
http://www.bluehostforum.com/showpost.php?p=31006&postcount=6
Could useful to you analise the solution proposed.

I'll wait you to say me which is the best way.

regards
carlo
Carlo
 
Posts: 6
Joined: Wed Apr 25, 2007 7:57 am
Location: São Paulo - BRAZIL

Postby asmecher » Thu Apr 26, 2007 1:16 pm

Hi Carlo,

Off the top of my head, that sounds like the same problem. The patch should fix it; if it doesn't, let me know.

Regards,
Alec Smecher
Open Journal Systems Team
---
Don't miss the First International PKP Scholarly Publishing Conference
July 11 - 13, 2007, Vancouver, BC, Canada
http://ocs.sfu.ca/pkp2007/
asmecher
 
Posts: 8597
Joined: Wed Aug 10, 2005 12:56 pm

Postby Carlo » Thu Apr 26, 2007 9:54 pm

Hi Alec.
Yes, it fixed the problem.
I hope the Zend team make the correction for the next release.
regard
Carlo.
Carlo
 
Posts: 6
Joined: Wed Apr 25, 2007 7:57 am
Location: São Paulo - BRAZIL


Return to OJS Technical Support

Who is online

Users browsing this forum: Bing [Bot] and 3 guests

cron