You are viewing the PKP Support Forum | PKP Home Wiki

OJS URL in emails

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.

OJS URL in emails

Postby lhansard » Tue Apr 03, 2007 7:58 am

We are using an alias to our instance of OJS. I have the base_url in the config.inc.php file pointing to the alias. The alias shows on the web page. In the emails, it still shows the host server name. How do I make the emails show the alias URL? Thanks
Posts: 2
Joined: Mon Aug 21, 2006 11:31 am

Postby asmecher » Tue Apr 03, 2007 9:06 am

Hi lhansard,

Make sure you've set the base_url[index] and base_url[(journal path name here)] settings in config.inc.php as well; those should cause emails to use the right URL.

If the problem is in the email signature, you can fine-tune it manually on Journal Setup page 1. There are several other settings that contain URLs that are generated when the journal is created, such as on Journal Setup page 5, and you'll need to correct those manually as well if the URL has changed since the journal was created.

Alec Smecher
Open Journal Systems Team
Don't miss the First International PKP Scholarly Publishing Conference
July 11 - 13, 2007, Vancouver, BC, Canada
Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm

Return to OJS Technical Support

Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 2 guests