You are viewing the PKP Support Forum | PKP Home Wiki


Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.


Postby carras » Sun Mar 18, 2007 9:26 am

I tried to install OJS ver 2.1.1 on a remote web server (http://www.altervista.org) to study your package.

I follow all the steps described on README file but when I try to open the web browser to my site (http://www.carras.altervista.org/ojs/) these messages appear:

Notice: ini_set() has been disabled for security reasons in /membri2/carras/ojs/includes/driver.inc.php on line 39

Warning: import(core/Core.inc.php) [function.import]: failed to open stream: No such file or directory in /membri2/carras/ojs/includes/functions.inc.php on line 21

Fatal error: import() [function.require]: Failed opening required 'core/Core.inc.php' (include_path='.:') in /membri2/carras/ojs/includes/functions.inc.php on line 21

If I understand the first message is only a PHP “notice “ and I could delete it by editing the code (I have to put @ before the line 39, isn’t it?)

For the other messages I haven’t any idea: could you help me?

You have to consider that
-I tried to install OJS on a local web server and the process was OK
-I tried to install OJS version 1.1.10 on the same remote web server (http://www.carras.altervista.org/ojs_1/) and the installation was OK .

Thank in advance

Posts: 1
Joined: Sun Mar 18, 2007 9:02 am

Installation problems

Postby ramon » Wed Apr 11, 2007 2:33 pm


Looks like the server has disabled some important functionalities that are essential for OJS to work correctly.

I would suggest:
1 - Contact the support to see if they can fix the problems
2 - Move to another server that is configured to run OJS

You might ask them to install it before you close a contract to see if it works.
Usually they won't mind configuring it for you.

The ini_set() notice is important because OJS uses sessions to control users logged in.

The other 2 indicate that OJS is not being able to import files. It may be a PHP path problem, that Alec could answer better. Usually there is a standard path for PHP to import functions. If it is not configured to be changed by software, then it may be looking for the files in the wrong place.
Posts: 945
Joined: Wed Oct 15, 2003 6:15 am
Location: Brasí­lia/DF - Brasil

Postby asmecher » Wed Apr 11, 2007 2:40 pm

Hi carras,

Ramón's correct -- your server has disabled some PHP functions that OJS needs. You'll have to either ask your host to allow ini_set or you'll have to change hosts. As for the "Failed opening required 'core/Core.inc.php'" message, it may be a file permissions problem, but the most common cause is an incomplete installation. If you uploaded OJS via FTP, make sure that you uploaded everything. (OJS also uses the ini_set function to set the include path, so it might be related to the first problem.)

Alec Smecher
Open Journal Systems Team
Don't miss the First International PKP Scholarly Publishing Conference
July 11 - 13, 2007, Vancouver, BC, Canada
Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm

Return to OJS Technical Support

Who is online

Users browsing this forum: Google [Bot] and 7 guests