OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



to apply a patch

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

to apply a patch

Postby nelson » Fri Feb 23, 2007 12:31 pm

to apply the patch for expedite, shall I copy and paste the code to the php file instead of using the shell command?

tnx
Alf
nelson
 
Posts: 36
Joined: Fri Jan 12, 2007 6:17 am

Postby asmecher » Fri Feb 23, 2007 12:43 pm

Hi Alf,

If you don't have access to the patch tool, you can apply the patch by hand. There's information on the unified patch format available at http://en.wikipedia.org/wiki/Diff#Unified_format.

Regards,
Alec Smecher
Open Journal Systems Team
---
Don't miss the First International PKP Scholarly Publishing Conference
July 11 - 13, 2007, Vancouver, BC, Canada
http://ocs.sfu.ca/pkp2007/
asmecher
 
Posts: 8668
Joined: Wed Aug 10, 2005 12:56 pm

Postby nelson » Fri Feb 23, 2007 2:19 pm

dear alec,
thank you very much, i tried to use patch before on my linubox, but it didn't worked, then I open the patch file with Quanta, and I find it quite intuitive:

remove the lines with --

add the lines with ++

Now expedite works fine, but adding submission with expedite produce an error in TOC: the link to the document doesn't appear as PDF but as UNTITLED, as you can see in this screenshot:

Image

Anyway, I didn't understood before the value of expedite also because italian translation in last submission step means the opposite of the english equivalent.

Looking at the original: author.submit.expedite in local.xml

If this submission is in a format that is ready to be published without further review,...


a good italian translation is:

Se questa submission è in un formato pronto per la pubblicazione senza ulteriori processi di review


I hope you will change it as soon as possible.
regards
Alf
nelson
 
Posts: 36
Joined: Fri Jan 12, 2007 6:17 am

Postby asmecher » Fri Feb 23, 2007 2:28 pm

Hi Alf,

Thanks for the note on the translation; it'll be fixed in the next release. I suspect the problem with galley labels is due to a misconfiguration of PHP's mime_content_type function -- search this forum for mime_content_type and you'll find a lot of discussion. Most likely you'll need to configure it in PHP's php.ini configuration file. Once this is done, PDFs should be automatically detected and a galley label of "PDF" should be used. (You can correct existing galley labels as Editor on the submission's Editing page by clicking "Edit" next to the galley in question and changing the label there.)

Regards,
Alec Smecher
Open Journal Systems Team
---
Don't miss the First International PKP Scholarly Publishing Conference
July 11 - 13, 2007, Vancouver, BC, Canada
http://ocs.sfu.ca/pkp2007/
asmecher
 
Posts: 8668
Joined: Wed Aug 10, 2005 12:56 pm

Postby nelson » Fri Feb 23, 2007 2:37 pm

So, why if all the steps of editing process are done the galley label is right, and if I use expedite the label is wrong?

regards
Alf
nelson
 
Posts: 36
Joined: Fri Jan 12, 2007 6:17 am

Postby asmecher » Fri Feb 23, 2007 2:53 pm

Hi Alf,

Just to clarify: Is the original submission file a PDF? If so, OJS should be able to auto-detect the galley label to use. The same auto-detection applies when creating a galley; if it works in one place, it should work in the other. Let me know if I'm misunderstanding the situation.

Regards,
Alec Smecher
Open Journal Systems Team
---
Don't miss the First International PKP Scholarly Publishing Conference
July 11 - 13, 2007, Vancouver, BC, Canada
http://ocs.sfu.ca/pkp2007/
asmecher
 
Posts: 8668
Joined: Wed Aug 10, 2005 12:56 pm

Postby nelson » Fri Feb 23, 2007 3:10 pm

Yes Alec, the original file is always a PDF,

but if I follow the complete submission process, faking authors and all other roles, the label is: PDF

then if I submit the PDF with expedite the label appears as UNTITLED (if i'm submitting using the english version) or as SENZA TITOLO (if I'm submitting using the italian version)

thanks
Alf
nelson
 
Posts: 36
Joined: Fri Jan 12, 2007 6:17 am

Postby asmecher » Sat Feb 24, 2007 7:01 pm

Hi Alf,

Hmm; it's possible that I'm overlooking something, but could you double-check that the patch was applied correctly? Try installing the newest version of EditorAction.inc.php from http://pkp.sfu.ca/cvs/cvsweb.cgi/ojs2/classes/submission/editor/EditorAction.inc.php. (This should be the same as the patched version.)

Regards,
Alec Smecher
Open Journal Systems Team
---
Don't miss the First International PKP Scholarly Publishing Conference
July 11 - 13, 2007, Vancouver, BC, Canada
http://ocs.sfu.ca/pkp2007/
asmecher
 
Posts: 8668
Joined: Wed Aug 10, 2005 12:56 pm

Postby nelson » Mon Feb 26, 2007 4:04 pm

Hi Alec,
I installed the newest wersion of EditorAction.inc.php, and I tried to make a submission, the error is still here.

Using the OJS in italian translation the label is: SENZA TITOLO

using it in english translation the label is: UNTITLED

and I have to change them by hand.

Thank you
Alfredo
nelson
 
Posts: 36
Joined: Fri Jan 12, 2007 6:17 am


Return to OJS Technical Support

Who is online

Users browsing this forum: Bing [Bot], cedavid and 8 guests