OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Running OCS with Apache running on non-default port

Are you responsible for making OCS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, michael, John

Forum rules
What to do if you have a technical problem with OCS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved. Please note that this FAQ is OJS-centric, but most issues are applicable to both platforms.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OCS Conference Support and Discussion subforum; if you have a development question, try the OCS Development subforum.

Running OCS with Apache running on non-default port

Postby ll » Wed Jan 24, 2007 12:54 am

Dear Technoids,

I have a WAMP server running on Box A (Windows 2003, Apache 2.2.3, MySQL 3.23 and PHP 4.4.4) and I can get OCS to run without any hazzles if I run Apache on port 80.

I need move this isnatllation onto another box (Box B) where IIS is running on port 80 already, which I can not move.

So before embarking on the migration, I reinstalled OCS on Box A after pointing Apache to port 83. During the OCS installation, I specfied the port (:83) in the base URL thinking that is all I need to do. Now I can not logon to the Admin interface - It will not accept the login credentials and move to the main administration page. if I key in wrong credentials, it tells me I have entered incorrect (username,password). IIS is not running in Box A, anyway.

What am I missing? HELP!!
ll
 
Posts: 10
Joined: Tue Jan 23, 2007 11:38 pm
Location: Queensland, Australia

Postby asmecher » Wed Jan 24, 2007 1:04 pm

Hi ll,

Sounds like you have a problem with cookies. If your browser configuration is OK (i.e. it's not set to disable cookies), you may have a conflict. Try deleting cookies named "confuser" and "confadmin" from your browser and logging in again. The port configuration shouldn't affect anything. Is your server proxied? If so, the cookie may not be getting through because of your proxy config.

Regards,
Alec Smecher
Public Knowledge Project Team
---
Don't miss the First International PKP Scholarly Publishing Conference
July 11 - 13, 2007, Vancouver, BC, Canada
http://ocs.sfu.ca/pkp2007/
asmecher
 
Posts: 9220
Joined: Wed Aug 10, 2005 12:56 pm

Postby ll » Wed Jan 24, 2007 6:48 pm

Hi Alec,

Thanks for the prompt response.

Tried what U suggested but no joy. Wanted to see whether I can replicate the problem and did the following:
Reconfigured Apache pointing to Port 80 and then reinstalled OCS. Worked like a dream. Reconfigured Apache pointing to port 800 this time and re-installed OCS. Same problem as with port 83 scenario - can not go past authentication screen in conference administration.

I feel I am missimng something somwehere. My WAMP server is basically an Xampp installtion and only place I need to make changes to refelct port change is in httpd.cnf - am I wrong?

TA
ll
ll
 
Posts: 10
Joined: Tue Jan 23, 2007 11:38 pm
Location: Queensland, Australia

Postby asmecher » Thu Jan 25, 2007 12:33 pm

Hi ll,

OCS doesn't specify the port number anywhere and it tends to use relative URLs, so I'm not sure what the problem is. Could you check the cookie that is being set? When you attempt to log in, you should receive a confadmin cookie from the user. Check in your browser to see what its various parameters are. In Firefox, for example, you can go to Edit -> Preferences -> Privacy -> Cookies -> View Cookies. Report the cookie's domain, path, and expiry date.

Regards,
Alec Smecher
Public Knowledge Project Team
---
Don't miss the First International PKP Scholarly Publishing Conference
July 11 - 13, 2007, Vancouver, BC, Canada
http://ocs.sfu.ca/pkp2007/
asmecher
 
Posts: 9220
Joined: Wed Aug 10, 2005 12:56 pm

Postby ll » Thu Feb 01, 2007 4:02 pm

Hi Alec,

I finally moved IIS running on port 80 and free up the default port. Which means OCS is running on port 80.

By the way, I have send a couple of emails (to PKP Contact) checking for the release date for OCS version 2. Do U have an idea when this would be available? I wish to use OCS for one of our upcoming conference and test-out and make use of on-line payments.

Thanks once again.
ll
[quote="asmecher"]Hi ll,

OCS doesn't specify the port number anywhere and it tends to use relative URLs, so I'm not sure what the problem is. Could you check the cookie that is being set? When you attempt to log in, you should receive a confadmin cookie from the user. Check in your browser to see what its various parameters are. In Firefox, for example, you can go to Edit -> Preferences -> Privacy -> Cookies -> View Cookies. Report the cookie's domain, path, and expiry date.

Regards,
Alec Smecher
Public Knowledge Project Team
---
Don't miss the First International PKP Scholarly Publishing Conference
July 11 - 13, 2007, Vancouver, BC, Canada
http://ocs.sfu.ca/pkp2007/[/quote]
ll
 
Posts: 10
Joined: Tue Jan 23, 2007 11:38 pm
Location: Queensland, Australia

Postby asmecher » Thu Feb 01, 2007 8:16 pm

Hi ll,

Glad to hear you've gotten OCS working, although I'm still at a loss for what was causing the problem with non-standard port numbers.

We're shooting for March to release OCS 2.0 at this point.

Regards,
Alec Smecher
Open Journal Systems Team
---
Don't miss the First International PKP Scholarly Publishing Conference
July 11 - 13, 2007, Vancouver, BC, Canada
http://ocs.sfu.ca/pkp2007/
asmecher
 
Posts: 9220
Joined: Wed Aug 10, 2005 12:56 pm


Return to OCS Technical Support

Who is online

Users browsing this forum: No registered users and 1 guest