OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Notification of new submission not working

Are you an Editor, Author, or Journal Manager in need of help? Want to talk to us about workflow issues? This is your forum.

Moderators: jmacgreg, michael, vgabler, John

Forum rules
This forum is meant for general questions about the usability of OJS from an everyday user's perspective: journal managers, authors, and editors are welcome to post questions here, as are librarians and other support staff. We welcome general questions about the role of OJS and how the workflow works, as well as specific function- or user-related questions.

What to do if you have general, workflow or usability questions about OJS:

1. Read the documentation. We've written documentation to cover from OJS basics to system administration and code development, and we encourage you to read it.

2. take a look at the tutorials. We will continue to add tutorials covering OJS basics as time goes on.

3. Post a question. Questions are always welcome here, but if it's a technical question you should probably post to the OJS Technical Support subforum; if you have a development question, try the OJS Development subforum.

Notification of new submission not working

Postby jproven » Tue Feb 28, 2012 10:18 am

Hi

We are hosting several new journals on OJS 2.3.6

Our editors are not getting notifications of new submissions even though the options below are ticked in 'Manage notifications'

Submission Events
A new article, "Title", has been submitted.
Allow these types of notifications to appear in my notification feed.
Send me an email for these types of notifications.

All other types of notifications appear in the feed or by email if ticked, but not new submissions. I know we can set 3.6 so that a copy of the author's acknowledgement email can be sent to an editor, but wondered if there is a reason we are missing the notifications?

Thanks
Jackie
jproven
 
Posts: 3
Joined: Wed Nov 02, 2011 9:55 am

Re: Notification of new submission not working

Postby sarasi » Mon Sep 10, 2012 9:14 am

Hey,

I have the same problem. Any idea of how to get this work

Thanks
Regards
Sarasi

jproven wrote:Hi

We are hosting several new journals on OJS 2.3.6

Our editors are not getting notifications of new submissions even though the options below are ticked in 'Manage notifications'

Submission Events
A new article, "Title", has been submitted.
Allow these types of notifications to appear in my notification feed.
Send me an email for these types of notifications.

All other types of notifications appear in the feed or by email if ticked, but not new submissions. I know we can set 3.6 so that a copy of the author's acknowledgement email can be sent to an editor, but wondered if there is a reason we are missing the notifications?

Thanks
Jackie
sarasi
 
Posts: 2
Joined: Thu Sep 06, 2012 9:54 am

Re: Notification of new submission not working

Postby angevent » Wed Apr 09, 2014 1:33 am

Hi Alec,

why email notifications of new article/metadata modified/new issue/etc. haven't been sended anymore? Which could be the causes?

Thank you
Angelo
angevent
 
Posts: 29
Joined: Tue Jun 11, 2013 1:12 pm

Re: Notification of new submission not working

Postby asmecher » Wed Apr 09, 2014 7:57 am

Hi all,

Two things to check:
  • In the "Send a copy to this email address", have you entered an email address with screen name (e.g. "John Smith <jsmith@institution.edu>") or just the email address (e.g. "jsmith@institution.edu")? Make sure you're just including the email address, not the screen name.
  • As usual with email delivery problems, check your spam folder; if possible, check your web server's email log.
Email delivery problems are tricky to debug because the mail server will often accept the message for delivery, then it'll have a misadventure during delivery without giving any information back to OJS. It's hard for us to guess what happened to the message without further information from the mail server.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8673
Joined: Wed Aug 10, 2005 12:56 pm

Re: Notification of new submission not working

Postby angevent » Fri Apr 11, 2014 5:01 am

Dear Alec,

the email delivered with option "Send a copy to this email address" is ok, I'm referring to the emails sended with "Send me an email for these types of notifications."

Angelo
angevent
 
Posts: 29
Joined: Tue Jun 11, 2013 1:12 pm

Re: Notification of new submission not working

Postby asmecher » Fri Apr 11, 2014 10:12 am

Hi Angelo,

What version of OJS are you using? The first poster mentions OJS 2.3.6; if you're still using something that old, I'd suggest upgrading first. There have been a lot of changes, including to the notification code, since then.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8673
Joined: Wed Aug 10, 2005 12:56 pm

Re: Notification of new submission not working

Postby angevent » Tue May 20, 2014 8:58 am

asmecher wrote:What version of OJS are you using? The first poster mentions OJS 2.3.6; if you're still using something that old, I'd suggest upgrading first. There have been a lot of changes, including to the notification code, since then.

We are using OJS 2.4.3, Alec.

The problem is just with notification emails that I can manage in "Notification Settings" (Submission Events, Reviewing Events ect.).
All others notification emails (registration, NOTIFICATION OF AUTHOR SUBMISSION that I check on step 3.6) have been always delivered.

Also the notification feed doesn't work, so the problem may not be the mail server.

Regards,
Angelo
angevent
 
Posts: 29
Joined: Tue Jun 11, 2013 1:12 pm

Re: Notification of new submission not working

Postby tarcisiop » Mon May 26, 2014 6:02 am

Hello,

I had a big problem with e-mails, I think it had something to do with an RFC.
As everyone started to work after I made the following edition:

SMTPMailer.inc.php
Code: Select all
132                 //Ajuste USP para a frescura da RFC
133                 if(!(strpos($headers, 'From:') !== false)){
134                         if (!$this->send('From:', '<' . $sender. '>'))
135                                 return $this->disconnect('Frescura da RFC');
136                 }


Still SMTPMailer.inc.php
Code: Select all
202         function send($command, $data = '') {
203                 //Ajuste para envio pela USP
204                 $command= str_replace("\r\r\n", "\r\n", str_replace("\n", "\r\n", $command));
205                 $data = str_replace("\r\r\n", "\r\n", str_replace("\n", "\r\n", $data));
206                 $ret = @fwrite($this->socket, $command . (empty($data) ? '' : ' ' . $data) . "\r\n");
207                 if ($ret !== false)
208                         return true;
209                 return false;
210         }


Might not have any relationship with your problem, but it might be.
Good luck
tarcisiop
 
Posts: 27
Joined: Mon Apr 14, 2014 12:22 pm

Re: Notification of new submission not working

Postby angevent » Tue May 27, 2014 8:50 am

angevent wrote:
asmecher wrote:What version of OJS are you using? The first poster mentions OJS 2.3.6; if you're still using something that old, I'd suggest upgrading first. There have been a lot of changes, including to the notification code, since then.

We are using OJS 2.4.3, Alec.

The problem is just with notification emails that I can manage in "Notification Settings" (Submission Events, Reviewing Events ect.).
All others notification emails (registration, NOTIFICATION OF AUTHOR SUBMISSION that I check on step 3.6) have been always delivered.

Also the notification feed doesn't work, so the problem may not be the mail server.

Regards,
Angelo

Excuse me, it may be a problem that we can't solve?

As usual, thank you very much!
angevent
 
Posts: 29
Joined: Tue Jun 11, 2013 1:12 pm


Return to OJS Editorial Support and Discussion

Who is online

Users browsing this forum: No registered users and 2 guests

cron